summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 647b89dc03..731091ea7d 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2021, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -204,8 +205,11 @@ driver is known to work with these printers:
(find-files (string-append #$output
"/lib/cups/filter"))))))))
(native-inputs
- (list `(,glib "bin") ; for gdbus-codegen
- pkg-config))
+ (append (if (%current-target-system)
+ (list cups-minimal)
+ '())
+ (list `(,glib "bin") ; for gdbus-codegen
+ pkg-config)))
(inputs
(list avahi
fontconfig
@@ -315,7 +319,10 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
;; to a missing font. Substitute the last observed count.
(("(\\$count != )33" _ prefix)
(string-append prefix "39"))))))))
- (native-inputs (list config pkg-config))
+ (native-inputs (cons* config pkg-config
+ (if (%current-target-system)
+ (list this-package)
+ '())))
(inputs (list zlib gnutls))
(home-page "https://openprinting.github.io/cups")
(synopsis "The Common Unix Printing System")
@@ -522,6 +529,7 @@ should only be used as part of the Guix cups-pk-helper service.")
(sha256
(base32
"0ihv9ddjrjx5bdf8pwc2fvljkpfzq4qi9r2awm8dgky053v0bk7p"))
+ (patches (search-patches "hplip-usb-timeout.patch"))
(modules '((guix build utils)))
(snippet
'(begin