summaryrefslogtreecommitdiff
path: root/gnu/packages/cryptsetup.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cryptsetup.scm')
-rw-r--r--gnu/packages/cryptsetup.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/cryptsetup.scm b/gnu/packages/cryptsetup.scm
index 900b004a50..9df26edc77 100644
--- a/gnu/packages/cryptsetup.scm
+++ b/gnu/packages/cryptsetup.scm
@@ -32,7 +32,7 @@
(define-public cryptsetup
(package
(name "cryptsetup")
- (version "1.7.4")
+ (version "1.7.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/utils/cryptsetup/v"
@@ -40,7 +40,7 @@
"/" name "-" version ".tar.xz"))
(sha256
(base32
- "05m0ric8anrkl62smk8rafgi30j9jrxw20qzss9gnf4sywz8kkvw"))))
+ "1gail831j826lmpdx2gsc83lp3br6wfnwh3vqwxaa1nn1lfwsc1b"))))
(build-system gnu-build-system)
(inputs
`(("libgcrypt" ,libgcrypt)
@@ -81,8 +81,8 @@ files). This assumes LIBRARY uses Libtool."
'(#:configure-flags '("--disable-shared"
"--enable-static-cryptsetup"
- ;; 'libdevmapper.a' pulls in libpthread and libudev.
- "LIBS=-ludev -pthread")
+ ;; 'libdevmapper.a' pulls in libpthread, libudev and libm.
+ "LIBS=-ludev -pthread -lm")
#:allowed-references () ;this should be self-contained