summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm18
1 files changed, 12 insertions, 6 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 1c6e759c83..a0f675c1dc 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -709,16 +709,17 @@ BLAKE.")
(define-public rhash
(package
(name "rhash")
- (version "1.3.8")
+ (version "1.3.9")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/rhash/RHash/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rhash/RHash")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0k60ywyhwqwqxa2q2l85vwgf884hcgy31nxir3dqgz7ymib6llxy"))))
+ "06i49x1l21h2q7pfnf4crbmjyg8b9ad0qs10ywyyn5sjpi0c21wq"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -733,6 +734,11 @@ BLAKE.")
(lambda* (#:key outputs #:allow-other-keys)
(invoke "./configure"
(string-append "--prefix=" (assoc-ref outputs "out")))))
+ (add-before 'check 'patch-/bin/sh
+ (lambda _
+ (substitute* "Makefile"
+ (("/bin/sh") (which "sh")))
+ #t))
(add-after 'install 'install-library-extras
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke