summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 948bb8748f..1b7989e072 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1057,6 +1057,28 @@ featuring zero allocations, composability, and iterator-like interfaces.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-futures-core-preview
+ (package
+ (name "rust-futures-core-preview")
+ (version "0.3.0-alpha.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "futures-core-preview" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1xaq8m609k6cz8xydwhwp8xxyxigabcw1w9ngycfy0bnkg7iq52b"))))
+ (build-system cargo-build-system)
+ (arguments
+ '(#:tests? #f)) ; The only tests are doc tests, which fail.
+ (home-page "https://rust-lang-nursery.github.io/futures-rs/")
+ (synopsis "Core traits and types in for the @code{futures} library.")
+ (description "This crate provides the core traits and types in for the
+@code{futures} library.")
+ (license (list license:asl2.0
+ license:expat))))
+
(define-public rust-futures-cpupool
(package
(name "rust-futures-cpupool")