summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm38
1 files changed, 30 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 03fd6b71eb..f3f104fa7e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -55802,8 +55802,37 @@ fixed set of worker threads.")
introspection APIs.")
(license (list license:expat license:asl2.0))))
+(define-public rust-time-0.3
+ (package
+ (name "rust-time")
+ (version "0.3.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "time" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1b943jf54q1667i328x3z73fsjdhcqdqccxckx1nzwwaz9ygxvs1"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-itoa" ,rust-itoa-0.4)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-quickcheck" ,rust-quickcheck-1)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-time-macros" ,rust-time-macros-0.2))))
+ (home-page "https://github.com/time-rs/time")
+ (synopsis "Date and time library")
+ (description "This package provides a date and time library. It is fully
+interoperable with the standard library, and is mostly compatible with
+@code{#![no_std]}.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-time-0.2
(package
+ (inherit rust-time-0.3)
(name "rust-time")
(version "0.2.23")
(source
@@ -55813,7 +55842,6 @@ introspection APIs.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "12z95k0005rmyn9pf9v4hq80khsns7y5wfydnjr5jpci2yiyxnmw"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-const-fn" ,rust-const-fn-0.4)
@@ -55828,13 +55856,7 @@ introspection APIs.")
#:cargo-development-inputs
(("rust-rand" ,rust-rand-0.7)
("rust-serde-json" ,rust-serde-json-1)
- ("rust-standback" ,rust-standback-0.2))))
- (home-page "https://github.com/time-rs/time")
- (synopsis "Date and time library")
- (description "This package provides a date and time library. It is fully
-interoperable with the standard library, and is mostly compatible with
-@code{#![no_std]}.")
- (license (list license:expat license:asl2.0))))
+ ("rust-standback" ,rust-standback-0.2))))))
(define-public rust-time-0.1
(package