summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 101e346ffe..06b76f1fee 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -12883,6 +12883,28 @@ cryptographic implementations.")
(properties '((hidden? . #t)))
(license license:expat)))
+(define-public rust-syntex-pos-0.58
+ (package
+ (name "rust-syntex-pos")
+ (version "0.58.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "syntex_pos" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0iqhircpr723da1g97xrrj8smqqz3gxw91cf03sckasjzri4gb8k"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-rustc-serialize" ,rust-rustc-serialize-0.3))))
+ (home-page "https://github.com/serde-rs/syntex")
+ (synopsis "Backport of libsyntax_pos")
+ (description "This package provides a backport of @code{libsyntax_pos}.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-sysctl-0.4
(package
(name "rust-sysctl")