summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 21 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cfdab81ec3..20ef86aff5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -17364,8 +17364,28 @@ implementation that is more efficient for smaller hash keys.")
syntax, as used by HTML forms.")
(license (list license:expat license:asl2.0))))
+(define-public rust-fragile-1
+ (package
+ (name "rust-fragile")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "fragile" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1wlihmkjyhvl5rckal32p010piy1l15s6l81h7z31jcd971kk839"))))
+ (build-system cargo-build-system)
+ (arguments `(#:skip-build? #t))
+ (home-page "https://github.com/mitsuhiko/rust-fragile")
+ (synopsis "Wrapper types for sending non-send values to other threads")
+ (description "This package provides wrapper types for sending non-send
+values to other threads.")
+ (license license:asl2.0)))
+
(define-public rust-fragile-0.3
(package
+ (inherit rust-fragile-1)
(name "rust-fragile")
(version "0.3.0")
(source
@@ -17376,13 +17396,7 @@ syntax, as used by HTML forms.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1yf2hmkw52x2dva3c9km1x8c2z5kwby7qqn8kz5ms3gs480i9y05"))))
- (build-system cargo-build-system)
- (home-page "https://github.com/mitsuhiko/rust-fragile")
- (synopsis "Wrapper types for sending non-send values to other threads")
- (description "This package provides wrapper types for sending non-send
-values to other threads.")
- (license license:asl2.0)))
+ "1yf2hmkw52x2dva3c9km1x8c2z5kwby7qqn8kz5ms3gs480i9y05"))))))
(define-public rust-freetype-0.4
(package