summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a39738697d..eb385f846f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -3012,7 +3012,7 @@ traits.")
(("rust-serde" ,rust-serde-1)
("rust-serde-test" ,rust-serde-test-1))))
(home-page "https://github.com/tomprogrammer/rust-ascii")
- (synopsis "ASCII-only equivalents to `char`, `str` and `String`.")
+ (synopsis "ASCII-only equivalents to `char`, `str` and `String`")
(description
"A rust library that provides ASCII-only string and character types,
equivalent to the @code{char}, @code{str} and @code{String} types in the
@@ -5243,7 +5243,7 @@ that uses Serde for transforming structs into bytes and vice versa!")
("rust-shlex" ,rust-shlex-1)
("rust-which" ,rust-which-4))))
(home-page "https://rust-lang.github.io/rust-bindgen/")
- (synopsis "Generate Rust FFI bindings to C and C++ libraries.")
+ (synopsis "Generate Rust FFI bindings to C and C++ libraries")
(description "This package can be used to automatically generate Rust FFI
bindings to C and C++ libraries.")
(license license:bsd-3)))
@@ -7551,7 +7551,7 @@ memory usage.")
(("rust-serde" ,rust-serde-1)
("rust-utf8-width" ,rust-utf8-width-0.1))))
(home-page "https://magiclen.org/byte-unit")
- (synopsis "Library for interaction with units of bytes.")
+ (synopsis "Library for interaction with units of bytes")
(description
"This package provides a library for interaction with units of bytes.")
(license license:expat)))
@@ -9880,7 +9880,7 @@ pitfalls in Rust.")
("rust-serde" ,rust-serde-1)
("rust-winapi" ,rust-winapi-0.3))))
(home-page "https://github.com/niklasmohrin/clircle")
- (synopsis "Detect IO circles in your CLI apps arguments.")
+ (synopsis "Detect IO circles in your CLI apps arguments")
(description
"Clircle provides a cross-platform API to detect read or write cycles
from your user-supplied arguments. You can get the important identifiers of
@@ -14108,7 +14108,7 @@ reading attributes into structs when implementing custom derives.")
("rust-rayon" ,rust-rayon-1)
("rust-serde" ,rust-serde-1))))
(home-page "https://github.com/xacrimon/dashmap")
- (synopsis "Blazing fast concurrent HashMap for Rust.")
+ (synopsis "Blazing fast concurrent HashMap for Rust")
(description "This package implements a blazing fast concurrent HashMap
for Rust.")
(license license:expat)))
@@ -15203,7 +15203,7 @@ procedural macros.")
("rust-num-traits" ,rust-num-traits-0.2)
("rust-time" ,rust-time-0.2))))
(home-page "https://github.com/krolaw/dhcp4r")
- (synopsis "IPv4 DHCP library with working server example.")
+ (synopsis "IPv4 DHCP library with working server example")
(description
"This package provides a library for IPv4 DHCP including a working server
example.")
@@ -18481,7 +18481,7 @@ is defined in the HTML specification.")
(build-system cargo-build-system)
(arguments `(#:skip-build? #t))
(home-page "https://github.com/aldanor/fast-float-rust")
- (synopsis "Fast floating-point number parser.")
+ (synopsis "Fast floating-point number parser")
(description
"This crate provides a fast decimal number parser from strings into
floats.")
@@ -20034,7 +20034,7 @@ macOS API for file changes notifications")
#:cargo-inputs
(("rust-utf8-ranges" ,rust-utf8-ranges-1))))
(home-page "https://github.com/BurntSushi/fst")
- (synopsis "Represent sets or maps of large numbers of strings.")
+ (synopsis "Represent sets or maps of large numbers of strings")
(description
"Use finite state transducers to compactly represent sets or maps of many
strings (> 1 billion is possible).")
@@ -20321,7 +20321,7 @@ featuring zero allocations, composability, and iterator-like interfaces.")
(build-system cargo-build-system)
(arguments '(#:tests? #f))
(home-page "https://rust-lang-nursery.github.io/futures-rs/")
- (synopsis "Core traits and types in for the @code{futures} library.")
+ (synopsis "Core traits and types in for the @code{futures} library")
(description "This crate provides the core traits and types in for the
@code{futures} library.")
(license (list license:asl2.0
@@ -24336,7 +24336,7 @@ HTTP request or response body.")
("rust-serde-urlencoded" ,rust-serde-urlencoded-0.7)
("rust-url" ,rust-url-2))))
(home-page "https://github.com/http-rs/http-types")
- (synopsis "Common types for HTTP operations.")
+ (synopsis "Common types for HTTP operations")
(description
"This package provides common types for HTTP operations.")
(license (list license:expat license:asl2.0))))
@@ -24498,7 +24498,7 @@ SystemTime}}.")
("rust-tracing" ,rust-tracing-0.1)
("rust-want" ,rust-want-0.3))))
(home-page "https://hyper.rs")
- (synopsis "Fast and correct HTTP library.")
+ (synopsis "Fast and correct HTTP library")
(description "This package provides a fast and correct HTTP library.")
(license license:expat)))
@@ -25226,7 +25226,7 @@ crate.")
("rust-rand" ,rust-rand-0.7)
("rust-serde-derive" ,rust-serde-derive-1))))
(home-page "https://github.com/bluss/indexmap")
- (synopsis "Hash table with consistent order and fast iteration.")
+ (synopsis "Hash table with consistent order and fast iteration")
(description
"This package provides a hash table with consistent order and fast iteration.
@@ -30907,7 +30907,7 @@ file's MIME type by its extension.")
(base32 "0xynhr97vyv5n5lls41dl7bfa3ba122lix9mqij1l7yprl6n6r4w"))))
(build-system cargo-build-system)
(home-page "https://github.com/Alexhuszagh/minimal-lexical")
- (synopsis "Fast float parsing conversion routines.")
+ (synopsis "Fast float parsing conversion routines")
(description "Fast float parsing conversion routines.")
(license (list license:expat license:asl2.0))))
@@ -35208,7 +35208,7 @@ contents.")
(build-system cargo-build-system)
(arguments `(#:skip-build? #t))
(home-page "https://hg.sr.ht/~icefox/oorandom")
- (synopsis "A tiny, robust PRNG implementation.")
+ (synopsis "A tiny, robust PRNG implementation")
(description
"This package provides a tiny, robust PRNG implementation.")
(license license:expat)))
@@ -44643,7 +44643,7 @@ please consider using @code{async-std} or @code{tokio}.")
#:cargo-inputs
(("rust-futures-preview" ,rust-futures-preview-0.3))))
(home-page "https://github.com/rustasync/runtime")
- (synopsis "Traits to implement custom Runtimes.")
+ (synopsis "Traits to implement custom Runtimes")
(description "This package provides traits to implement custom Runtimes.")
(license (list license:expat license:asl2.0))))
@@ -49888,7 +49888,7 @@ exactly where a binary came from and how it was built.")
("rust-criterion" ,rust-criterion-0.3)
("rust-proptest" ,rust-proptest-0.9))))
(home-page "https://github.com/hawkw/sharded-slab")
- (synopsis "Lock-free concurrent slab.")
+ (synopsis "Lock-free concurrent slab")
(description "This package provides a lock-free concurrent slab.")
(license license:expat)))
@@ -54559,7 +54559,7 @@ without a mutable reference.")
"0hvd6vk4ksgg2y99498jw52ric4lxm0i6ygpzqm95gdrhvsxyynp"))))
(build-system cargo-build-system)
(home-page "https://docs.rs/takeable-option/")
- (synopsis "A small wrapper around option.")
+ (synopsis "A small wrapper around option")
(description
"This package provides a small wrapper around option.")
(license (list license:asl2.0 license:expat))))
@@ -58839,7 +58839,7 @@ composition between @code{Service}s.")
`(#:cargo-development-inputs
(("rust-http" ,rust-http-0.1))))
(home-page "https://github.com/tower-rs/tower")
- (synopsis "Asynchronous, request / response based, client or server.")
+ (synopsis "Asynchronous, request / response based, client or server")
(description "This package provides a trait representing an asynchronous,
request/response based, client or server.")
(license license:expat)))
@@ -60320,7 +60320,7 @@ the Trust-DNS client to use rustls for TLS.")
(build-system cargo-build-system)
(arguments `(#:skip-build? #t))
(home-page "https://github.com/RazrFalcon/ttf-parser")
- (synopsis "A high-level, safe, zero-allocation TrueType font parser.")
+ (synopsis "A high-level, safe, zero-allocation TrueType font parser")
(description
"This package provides a high-level, safe, zero-allocation TrueType font
parser.")