summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm42
1 files changed, 34 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5c0395cdcf..a8a6163617 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -46070,8 +46070,41 @@ no_std compatible by default, only relying on alloc.")
("rust-errno" ,rust-errno-0.2)
("rust-libc" ,rust-libc-0.2))))))
+(define-public rust-sysinfo-0.18
+ (package
+ (name "rust-sysinfo")
+ (version "0.18.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "sysinfo" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0zd974yydc4yszxgx9hiqm5ah2rqnsgyq3qrl7raf90scpxaw16l"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-core-foundation-sys" ,rust-core-foundation-sys-0.8)
+ ("rust-doc-comment" ,rust-doc-comment-0.3)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-ntapi" ,rust-ntapi-0.3)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-rayon" ,rust-rayon-1)
+ ("rust-winapi" ,rust-winapi-0.3))))
+ (home-page "https://github.com/GuillaumeGomez/sysinfo")
+ (synopsis "System handler to interact with processes")
+ (description
+ "This package is a library to get system information such as processes,
+processors, disks, components and networks.")
+ (license license:expat)))
+
(define-public rust-sysinfo-0.16
(package
+ (inherit rust-sysinfo-0.18)
(name "rust-sysinfo")
(version "0.16.5")
(source
@@ -46081,7 +46114,6 @@ no_std compatible by default, only relying on alloc.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "06x5kvd4glq35jjy23xj8p7nd64dk8g4kc0v9qdfhyr0y0792zjn"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
@@ -46092,13 +46124,7 @@ no_std compatible by default, only relying on alloc.")
("rust-ntapi" ,rust-ntapi-0.3)
("rust-once-cell" ,rust-once-cell-1)
("rust-rayon" ,rust-rayon-1)
- ("rust-winapi" ,rust-winapi-0.3))))
- (home-page "https://github.com/GuillaumeGomez/sysinfo")
- (synopsis "System handler to interact with processes")
- (description
- "This package is a library to get system information such as processes,
-processors, disks, components and networks.")
- (license license:expat)))
+ ("rust-winapi" ,rust-winapi-0.3))))))
(define-public rust-syslog-4
(package