summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm40
1 files changed, 33 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a1388d9ae6..0dc1fa8c4c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -38613,18 +38613,44 @@ written with declarative macros.")
(description "This crate provides utilities for pinning values on the stack.")
(license (list license:expat license:asl2.0))))
+(define-public rust-pkcs1-0.2
+ (package
+ (name "rust-pkcs1")
+ (version "0.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pkcs1" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0b2f1a0lf5h53zrjvcqbxzjhh89gcfa1myhf6z7w10ypg61fwsqi"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-der" ,rust-der-0.4)
+ ("rust-pem-rfc7468" ,rust-pem-rfc7468-0.2)
+ ("rust-zeroize" ,rust-zeroize-1))))
+ (home-page "https://github.com/RustCrypto/formats/tree/master/pkcs1")
+ (synopsis "Implementation of Public-Key Cryptography Standards (PKCS) #1")
+ (description
+ "This package provides a pure Rust implementation of Public-Key
+Cryptography Standards (PKCS) #1: RSA Cryptography Specifications Version 2.2
+(RFC 8017)")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-pkg-config-0.3
(package
(name "rust-pkg-config")
(version "0.3.19")
(source
- (origin
- (method url-fetch)
- (uri (crate-uri "pkg-config" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0k4860955riciibxr8bhnklp79jydp4xfylwdn5v9kj96hxlac9q"))))
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pkg-config" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0k4860955riciibxr8bhnklp79jydp4xfylwdn5v9kj96hxlac9q"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-development-inputs