summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 70654f696d..459c1a58c8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -44521,6 +44521,26 @@ Pwrite traits from the scroll crate.")
proven statistical guarantees.")
(license license:expat)))
+(define-public rust-seahash-4
+ (package
+ (name "rust-seahash")
+ (version "4.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "seahash" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0sxsb64np6bvnppjz5hg4rqpnkczhsl8w8kf2a5lr1c08xppn40w"))))
+ (build-system cargo-build-system)
+ (arguments '(#:skip-build? #t))
+ (home-page "https://gitlab.redox-os.org/redox-os/seahash")
+ (synopsis "Hash function with proven statistical guarantees")
+ (description
+ "This package provides a fast, portable hash function with proven
+statistical guarantees.")
+ (license license:expat)))
+
(define-public rust-seccomp-sys-0.1
(package
(name "rust-seccomp-sys")