summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1ac9e4b033..b316a3c05f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -156,6 +156,25 @@ can limit either their total size or the age of the oldest object (or both),
automatically pruning objects to maintain the constraints.")
(license license:expat)))
+(define-public r-collections
+ (package
+ (name "r-collections")
+ (version "0.3.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "collections" version))
+ (sha256
+ (base32 "053ig88pva78wxxwya3v7cz853k563dkpgxrf2xvd0l0d9fanxmz"))))
+ (properties `((upstream-name . "collections")))
+ (build-system r-build-system)
+ (home-page "https://github.com/randy3k/collections")
+ (synopsis "High performance container data types")
+ (description
+ "This package provides high performance container data types such as
+queues, stacks, deques, dicts and ordered dicts.")
+ (license license:expat)))
+
(define-public r-curry
(package
(name "r-curry")