summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm44
1 files changed, 21 insertions, 23 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 411e5a9820..a740bf1aa9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -461,6 +461,24 @@ print, summary, plot, update, etc.
@end itemize\n")
(license license:gpl2)))
+(define-public r-ps
+ (package
+ (name "r-ps")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ps" version))
+ (sha256
+ (base32 "1zm9qkyvy1fvcjvmgw51iqw8x1xzkpy7rx7xnchwfj0xpzal0ljx"))))
+ (build-system r-build-system)
+ (home-page "http://ps.r-lib.org")
+ (synopsis "List, query, and manipulate system processes")
+ (description
+ "The ps package implements an API to list, query, and manipulate system
+processes. Most of its code is based on the @code{psutil} Python package.")
+ (license license:bsd-3)))
+
(define-public r-rcpp
(package
(name "r-rcpp")
@@ -2459,18 +2477,19 @@ constants, and control debugging of packages via environment variables.")
(define-public r-processx
(package
(name "r-processx")
- (version "3.1.0")
+ (version "3.2.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "processx" version))
(sha256
(base32
- "0wjr3cqwvnjxbvln25szffmkns5w0xysivdjr6chxap4nh515b0i"))))
+ "1pzx4ap4xa07gf9zkd6hacdsnb9sp3kb60a7v7ljl0ywrcpn1fn4"))))
(build-system r-build-system)
(propagated-inputs
`(("r-assertthat" ,r-assertthat)
("r-crayon" ,r-crayon)
+ ("r-ps" ,r-ps)
("r-r6" ,r-r6)
("r-testthat" ,r-testthat)))
(home-page "https://github.com/r-lib/processx3")
@@ -4767,27 +4786,6 @@ approach is the identification of genomic regions, genes, or gene sets
containing one or more SNPs that evolved under directional selection.")
(license license:gpl2)))
-(define-public r-hash
- (package
- (name "r-hash")
- (version "2.2.6")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "hash" version))
- (sha256
- (base32
- "0mkx59bmni3b283znvbndnkbar85fzavzdfgmwrhskidsqcz34yz"))))
- (build-system r-build-system)
- (home-page "https://cran.r-project.org/web/packages/hash/")
- (synopsis "Implementation of hash/associated arrays/dictionaries")
- (description
- "This package implements a data structure similar to hashes in Perl and
-dictionaries in Python but with a purposefully R flavor. For objects of
-appreciable size, access using hashes outperforms native named lists and
-vectors.")
- (license license:gpl2+)))
-
(define-public r-proc
(package
(name "r-proc")