summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm46
1 files changed, 34 insertions, 12 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 9ab6e0b835..87bf66d1d1 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -18,6 +18,9 @@
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Milkey Mouse <milkeymouse@meme.institute>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -87,11 +90,13 @@
(commit version)))
(file-name
(git-file-name name version))
+ (patches (search-patches "range-v3-build-with-gcc10.patch"))
(sha256
(base32 "18230bg4rq9pmm5f8f65j444jpq56rld4fhmpham8q3vr1c1bdjh"))))
(build-system cmake-build-system)
(native-inputs
`(("doxygen" ,doxygen)
+ ("gcc" ,gcc-9)
("perl" ,perl)))
(inputs
`(("boost" ,boost)))
@@ -129,7 +134,8 @@ range-v3 ranges are an abstraction layer on top of iterators.")
(git-file-name name version))
(patches
(search-patches
- "c++-gsl-find-system-gtest.patch"))
+ "c++-gsl-find-system-gtest.patch"
+ "c++-gsl-move-array-bounds-tests.patch"))
(sha256
(base32 "0gbvr48f03830g3154bjhw92b8ggmg6wwh5xyb8nppk9v6w752l0"))))
(build-system cmake-build-system)
@@ -365,10 +371,8 @@ functions, class methods, and stl containers.
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(inc (string-append out "/include/fifo_map")))
- (with-directory-excursion
- (string-append "../" ,name "-" ,version "-checkout")
- (install-file "src/fifo_map.hpp" inc)
- #t)))))))
+ (with-directory-excursion "../source"
+ (install-file "src/fifo_map.hpp" inc))))))))
(synopsis "FIFO-ordered associative container for C++")
(description "Fifo_map is a C++ header only library for associative
container which uses the order in which keys were inserted to the container
@@ -703,7 +707,7 @@ code and retrieving their output.")
(define-public sobjectizer
(package
(name "sobjectizer")
- (version "5.6.1")
+ (version "5.7.2.6")
(source
(origin
(method git-fetch)
@@ -711,7 +715,7 @@ code and retrieving their output.")
(url "https://github.com/Stiffstream/sobjectizer")
(commit (string-append "v." version))))
(sha256
- (base32 "0jfai7sqxnnjkms38krm7mssj5l79nb3pllkbyj4j581a7l5j6l5"))
+ (base32 "0n6smpjkkkw0xab8wcpy3p0dpw2v9sxgwl6azl3am6abmv4mff12"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
@@ -759,7 +763,8 @@ other values of screen objects, by setting their values as the tween starting
point and then, after each tween step, plugging back the result.")
(license license:expat)))
-(define-public abseil-cpp
+;;; This older LTS release is kept for tensorflow.
+(define-public abseil-cpp-20200923.3
(package
(name "abseil-cpp")
(version "20200923.3")
@@ -772,11 +777,8 @@ point and then, after each tween step, plugging back the result.")
(sha256
(base32
"1p4djhm1f011ficbjjxx3n8428p8481p20j4glpaawnpsi362hkl"))
- ;; Remove after next googletest release and update.
(patches
- (search-patches
- "abseil-cpp-fix-gtest.patch"
- "abseil-cpp-fix-strerror_test.patch"))))
+ (search-patches "abseil-cpp-fix-strerror_test.patch"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
@@ -809,6 +811,26 @@ augment the C++ standard library. The Abseil library code is collected from
Google's C++ code base.")
(license license:asl2.0)))
+(define-public abseil-cpp
+ (let ((base abseil-cpp-20200923.3))
+ (package/inherit base
+ (name "abseil-cpp")
+ (version "20210324.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/abseil/abseil-cpp")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g9rbhk3mwjdfxk7cscd04vm8fphd5flz9yykpgvyy1nwa34zk3x"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments base)
+ ((#:configure-flags flags)
+ `(cons* "-DBUILD_TESTING=ON"
+ (delete "-DABSL_RUN_TESTS=ON" ,flags))))))))
+
(define-public pegtl
(package
(name "pegtl")