summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 32b6dad497..003883e1a5 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -493,6 +494,36 @@ it's own version of the tool, this is a fork that aims to be more responsive
and make @code{cpplint} usable in wider contexts.")
(license license:bsd-3)))
+(define-public reproc
+ (package
+ (name "reproc")
+ (version "14.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DaanDeMeyer/reproc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1n71wb50qv2dmhjgw7azx5gigbrp19l2n3d41g9p05l5l0y1qg0q"))))
+ (build-system cmake-build-system)
+ (arguments
+ ;; No tests.
+ `(#:tests? #f
+ ;; Enable building of shared library.
+ #:configure-flags `("-DBUILD_SHARED_LIBS=1")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Process IO library")
+ (description "reproc (Redirected Process) is a C/C++ library that
+simplifies starting, stopping and communicating with external programs. The
+main use case is executing command line applications directly from C or C++
+code and retrieving their output.")
+ (home-page "https://github.com/DaanDeMeyer/reproc")
+ (license license:expat)))
+
(define-public sobjectizer
(package
(name "sobjectizer")