summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm26
1 files changed, 14 insertions, 12 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d591e6a884..4e8f12248f 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -41,12 +41,15 @@
(version "0.4.37")
(source (origin
(method url-fetch)
+ ;; Warning: This source has proved unreliable 1 time at least.
+ ;; Consider an alternate source or report upstream if this
+ ;; happens again.
(uri (string-append "https://mediaarea.net/download/source/"
name "/" version "/"
name "_" version ".tar.bz2"))
(sha256
(base32
- "1hcsrmn85b0xp0mp33aazk7g071q1v3f163nnhv8b0mv9c4bgsfn"))))
+ "1dkqbgabzpa6bd7dkqrvd35sdxrhr6qxalb88f3dw0afk65xqb0k"))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -58,10 +61,8 @@
(modify-phases %standard-phases
(add-after 'unpack 'pre-configure
(lambda _
- (chdir "Project/GNU/Library")))
- (add-after 'pre-configure 'autogen
- (lambda _
- (zero? (system* "sh" "autogen.sh")))))))
+ (chdir "Project/GNU/Library")
+ #t)))))
(home-page "https://github.com/MediaArea/ZenLib")
(synopsis "C++ utility library")
(description "ZenLib is a C++ utility library. It includes classes for handling
@@ -202,15 +203,16 @@ as ordering relation.")
(package
(name "json-modern-cxx")
(version "3.1.2")
+ (home-page "https://github.com/nlohmann/json")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/nlohmann/json/archive/v" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "v" version))))
(sha256
(base32
- "0m5fhdpx2qll933db2nsi30nns3cifavzvijzz6mxhdkpmngmzz8"))
- (file-name (string-append name "-" version ".tar.gz"))
+ "1mpr781fb2dfbyscrr7nil75lkxsazg4wkm749168lcf2ksrrbfi"))
+ (file-name (git-file-name name version))
(modules '((guix build utils)))
(snippet
'(begin
@@ -226,13 +228,13 @@ as ordering relation.")
(substitute* files
(("#include ?\"(fifo_map.hpp)\"" all fifo-map-hpp)
(string-append
- "#include <fifo_map/" fifo-map-hpp ">")))))))))
+ "#include <fifo_map/" fifo-map-hpp ">")))))
+ #t))))
(native-inputs
`(("amalgamate" ,amalgamate)))
(inputs
`(("catch2" ,catch-framework2)
("fifo-map" ,fifo-map)))
- (home-page "https://github.com/nlohmann/json")
(build-system cmake-build-system)
(synopsis "JSON parser and printer library for C++")
(description "JSON for Modern C++ is a C++ JSON library that provides