summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm192
1 files changed, 93 insertions, 99 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 9ab6e0b835..1b6779a036 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -18,6 +18,9 @@
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Milkey Mouse <milkeymouse@meme.institute>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -87,14 +90,14 @@
(commit version)))
(file-name
(git-file-name name version))
+ (patches (search-patches "range-v3-build-with-gcc10.patch"))
(sha256
(base32 "18230bg4rq9pmm5f8f65j444jpq56rld4fhmpham8q3vr1c1bdjh"))))
(build-system cmake-build-system)
(native-inputs
- `(("doxygen" ,doxygen)
- ("perl" ,perl)))
+ (list doxygen gcc-9 perl))
(inputs
- `(("boost" ,boost)))
+ (list boost))
(synopsis "Range library for C++14/17/20")
(description "Range-v3 is an extension of the Standard Template Library that
makes its iterators and algorithms more powerful by making them composable.
@@ -129,13 +132,13 @@ range-v3 ranges are an abstraction layer on top of iterators.")
(git-file-name name version))
(patches
(search-patches
- "c++-gsl-find-system-gtest.patch"))
+ "c++-gsl-find-system-gtest.patch"
+ "c++-gsl-move-array-bounds-tests.patch"))
(sha256
(base32 "0gbvr48f03830g3154bjhw92b8ggmg6wwh5xyb8nppk9v6w752l0"))))
(build-system cmake-build-system)
(native-inputs
- `(("googletest" ,googletest)
- ("pkg-config" ,pkg-config)))
+ (list googletest pkg-config))
(synopsis "Guidelines Support Library")
(description "c++-gsl contains functions and types that are suggested for
use by the C++ Core Guidelines maintained by the Standard C++ Foundation.")
@@ -158,9 +161,7 @@ use by the C++ Core Guidelines maintained by the Standard C++ Foundation.")
(base32
"1rwaxmid9iv65n0y6xlcyxxydsvihjni9ldxpg6pbqz43amp49xx"))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
+ (list autoconf automake libtool))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -203,7 +204,7 @@ operating system functions.")
(substitute* "src/unit_tests/unit_tests.cmake"
(("misc/library_test.cpp") ""))
#t)))))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs (list pkg-config))
(home-page "https://github.com/rttrorg/rttr/")
(synopsis "C++ Reflection Library")
(description
@@ -234,11 +235,9 @@ the name of the library itself, which is written in C++.")
'("-DWITH_TESTS=ON" ; To run the test suite
"-DRCT_RTTI_ENABLED=ON")))
(native-inputs
- `(("cppunit" ,cppunit)
- ("pkg-config" ,pkg-config)))
+ (list cppunit pkg-config))
(inputs
- `(("openssl" ,openssl)
- ("zlib" ,zlib)))
+ (list openssl zlib))
(home-page "https://github.com/Andersbakken/rct")
(synopsis "C++ library providing Qt-like APIs on top of the STL")
(description "Rct is a set of C++ tools that provide nicer (more Qt-like)
@@ -261,7 +260,7 @@ the name of the library itself, which is written in C++.")
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments '(#:tests? #f)) ; no tests
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs (list pkg-config))
(home-page "https://github.com/aseba-community/dashel")
(synopsis "Data stream helper encapsulation library")
(description
@@ -289,7 +288,7 @@ combination of these streams.")
`(#:configure-flags (list "-DBUILD_TESTS=ON")
#:test-target "xtest"))
(native-inputs
- `(("googletest" ,googletest)))
+ (list googletest))
(home-page "https://github.com/QuantStack/xsimd")
(synopsis "C++ wrappers for SIMD intrinsics and math implementations")
(description
@@ -353,7 +352,7 @@ functions, class methods, and stl containers.
(modules '((guix build utils)))
(snippet '(delete-file-recursively "./test/thirdparty"))))
(native-inputs
- `(("catch2" ,catch-framework2-1)))
+ (list catch-framework2-1))
(build-system cmake-build-system)
(arguments
`(#:phases
@@ -365,10 +364,8 @@ functions, class methods, and stl containers.
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(inc (string-append out "/include/fifo_map")))
- (with-directory-excursion
- (string-append "../" ,name "-" ,version "-checkout")
- (install-file "src/fifo_map.hpp" inc)
- #t)))))))
+ (with-directory-excursion "../source"
+ (install-file "src/fifo_map.hpp" inc))))))))
(synopsis "FIFO-ordered associative container for C++")
(description "Fifo_map is a C++ header only library for associative
container which uses the order in which keys were inserted to the container
@@ -443,7 +440,7 @@ as ordering relation.")
(base32
"0nzsjzlvk14dazwh7k2jb1dinb0pv9jbx5jsyn264wvva0y7daiv")))))))
(inputs
- `(("fifo-map" ,fifo-map)))
+ (list fifo-map))
(synopsis "JSON parser and printer library for C++")
(description "JSON for Modern C++ is a C++ JSON library that provides
intuitive syntax and trivial integration.")
@@ -464,8 +461,7 @@ intuitive syntax and trivial integration.")
"1kd9zl4h6nrsg29hq13vwp4zhfj8sa90vj40726lpw6vxz48k4di"))
(file-name (git-file-name name version))))
(native-inputs
- `(("googletest" ,googletest)
- ("json-modern-cxx" ,json-modern-cxx)))
+ (list googletest json-modern-cxx))
(arguments
`(#:configure-flags
'("-DBUILD_TESTS=ON")
@@ -500,10 +496,9 @@ tools (containers, algorithms) used by other QuantStack packages.")
(arguments
'(#:tests? #f)) ; no check target
(inputs
- `(("rapidjson" ,rapidjson)))
+ (list rapidjson))
(native-inputs
- `(("clang" ,clang)
- ("llvm" ,llvm)))
+ (list clang llvm))
(home-page "https://github.com/MaskRay/ccls")
(synopsis "C/C++/Objective-C language server")
(description
@@ -554,11 +549,9 @@ lock-free fixed size queue written in C++11.")
;; https://bugs.gnu.org/46562
'(#:parallel-tests? #f))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ;; For tests.
- ("perl" ,perl)))
+ (list autoconf automake libtool
+ ;; For tests.
+ perl))
(home-page "https://github.com/gperftools/gperftools")
(synopsis "Multi-threaded malloc() and performance analysis tools for C++")
(description
@@ -622,11 +615,9 @@ tools:
(invoke "make"))))))))
(native-inputs
;; required to build shared lib
- `(("python" ,python)))
+ (list python))
(inputs
- `(("brotli" ,brotli)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
+ (list brotli openssl zlib))
(home-page "https://github.com/yhirose/cpp-httplib")
(synopsis "C++ HTTP/HTTPS server and client library")
(description "cpp-httplib is a C++11 single-file cross platform blocking
@@ -659,9 +650,7 @@ library.")
#t)))))
(build-system python-build-system)
(native-inputs
- `(("python-pytest" ,python-pytest)
- ("python-pytest-cov" ,python-pytest-cov)
- ("python-pytest-runner" ,python-pytest-runner)))
+ (list python-pytest python-pytest-cov python-pytest-runner))
(home-page "https://github.com/cpplint/cpplint")
(synopsis "Static code checker for C++")
(description "@code{cpplint} is a command-line tool to check C/C++ files
@@ -691,7 +680,7 @@ and make @code{cpplint} usable in wider contexts.")
;; Enable building of shared library.
#:configure-flags `("-DBUILD_SHARED_LIBS=1")))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(synopsis "Process IO library")
(description "reproc (Redirected Process) is a C/C++ library that
simplifies starting, stopping and communicating with external programs. The
@@ -703,7 +692,7 @@ code and retrieving their output.")
(define-public sobjectizer
(package
(name "sobjectizer")
- (version "5.6.1")
+ (version "5.7.2.6")
(source
(origin
(method git-fetch)
@@ -711,7 +700,7 @@ code and retrieving their output.")
(url "https://github.com/Stiffstream/sobjectizer")
(commit (string-append "v." version))))
(sha256
- (base32 "0jfai7sqxnnjkms38krm7mssj5l79nb3pllkbyj4j581a7l5j6l5"))
+ (base32 "0n6smpjkkkw0xab8wcpy3p0dpw2v9sxgwl6azl3am6abmv4mff12"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
@@ -759,7 +748,8 @@ other values of screen objects, by setting their values as the tween starting
point and then, after each tween step, plugging back the result.")
(license license:expat)))
-(define-public abseil-cpp
+;;; This older LTS release is kept for tensorflow.
+(define-public abseil-cpp-20200923.3
(package
(name "abseil-cpp")
(version "20200923.3")
@@ -772,11 +762,8 @@ point and then, after each tween step, plugging back the result.")
(sha256
(base32
"1p4djhm1f011ficbjjxx3n8428p8481p20j4glpaawnpsi362hkl"))
- ;; Remove after next googletest release and update.
(patches
- (search-patches
- "abseil-cpp-fix-gtest.patch"
- "abseil-cpp-fix-strerror_test.patch"))))
+ (search-patches "abseil-cpp-fix-strerror_test.patch"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
@@ -801,7 +788,7 @@ point and then, after each tween step, plugging back the result.")
(("check_target\\(gtest_main\\)") "")
(("check_target\\(gmock\\)") "")))))))
(native-inputs
- `(("googletest" ,googletest)))
+ (list googletest))
(home-page "https://abseil.io")
(synopsis "Augmented C++ standard library")
(description "Abseil is a collection of C++ library code designed to
@@ -809,6 +796,26 @@ augment the C++ standard library. The Abseil library code is collected from
Google's C++ code base.")
(license license:asl2.0)))
+(define-public abseil-cpp
+ (let ((base abseil-cpp-20200923.3))
+ (package/inherit base
+ (name "abseil-cpp")
+ (version "20210324.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/abseil/abseil-cpp")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g9rbhk3mwjdfxk7cscd04vm8fphd5flz9yykpgvyy1nwa34zk3x"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments base)
+ ((#:configure-flags flags)
+ `(cons* "-DBUILD_TESTING=ON"
+ (delete "-DABSL_RUN_TESTS=ON" ,flags))))))))
+
(define-public pegtl
(package
(name "pegtl")
@@ -871,26 +878,23 @@ standard GNU style syntax for options.")
;; Leave tests disabled; see https://github.com/facebook/folly/issues/1456
#:tests? #f))
(propagated-inputs
- `(("boost" ,boost)
- ("gflags" ,gflags)
- ("glog" ,glog)
- ("liburing" ,liburing)))
+ (list boost gflags glog liburing))
(inputs
- `(("bzip2" ,bzip2)
- ("double-conversion" ,double-conversion)
- ("fmt" ,fmt)
- ("libaio" ,libaio)
- ("libevent" ,libevent)
- ("libiberty" ,libiberty)
- ("libsodium" ,libsodium)
- ("libunwind" ,libunwind)
- ("lz4" ,lz4)
- ("openssl" ,openssl)
- ("snappy" ,snappy)
- ("zlib" ,zlib)
- ("zstd" ,zstd "lib")))
+ (list bzip2
+ double-conversion
+ fmt
+ libaio
+ libevent
+ libiberty
+ libsodium
+ libunwind
+ lz4
+ openssl
+ snappy
+ zlib
+ `(,zstd "lib")))
(native-inputs
- `(("googletest" ,googletest)))
+ (list googletest))
(synopsis "Collection of C++ components complementing the standard library")
(description
"Folly (acronymed loosely after Facebook Open Source Library) is a library
@@ -927,12 +931,12 @@ of C++14 components that complements @code{std} and Boost.")
(assoc-ref %build-inputs "aws-c-common"))
"-DENABLE_NET_TESTS=OFF")))
(propagated-inputs
- `(("aws-c-auth" ,aws-c-auth)
- ("aws-c-cal" ,aws-c-cal)
- ("aws-c-event-stream" ,aws-c-event-stream)
- ("aws-c-http" ,aws-c-http)
- ("aws-c-mqtt" ,aws-c-mqtt)
- ("aws-c-s3" ,aws-c-s3)))
+ (list aws-c-auth
+ aws-c-cal
+ aws-c-event-stream
+ aws-c-http
+ aws-c-mqtt
+ aws-c-s3))
(synopsis "C++ wrapper for Amazon Web Services C libraries")
(description "The AWS Common Runtime (CRT) library provides a C++ wrapper
implementation for the following @acronym{AWS,Amazon Web Services} C libraries:
@@ -966,12 +970,9 @@ aws-c-http, aws-c-io, aws-c-mqtt, aws-checksums, and s2n.")
(string-append "-DCMAKE_PREFIX_PATH="
(assoc-ref %build-inputs "aws-c-common")))))
(propagated-inputs
- `(("aws-crt-cpp" ,aws-crt-cpp)))
+ (list aws-crt-cpp))
(inputs
- `(("curl" ,curl)
- ("openssl" ,openssl)
- ("pulseaudio" ,pulseaudio)
- ("zlib" ,zlib)))
+ (list curl openssl pulseaudio zlib))
(synopsis "Amazon Web Services SDK for C++")
(description
"The AWS SDK for C++ provides a C++11 interface to the @acronym{AWS,Amazon
@@ -1007,7 +1008,7 @@ services including database, analytic, and machine learning technologies.")
(lambda _
(invoke "./tests"))))))
(native-inputs
- `(("catch2" ,catch-framework2)))
+ (list catch-framework2))
(synopsis "C++11/14/17 std::expected with functional-style extensions")
(description "@code{std::expected} is proposed as the preferred way to
represent objects which will either have an expected value, or an unexpected
@@ -1034,7 +1035,7 @@ provides a number of utilities to make coding with expected cleaner.")
"1x47radgsifgz3vn2561mlvf4cq46ii33cpyqf01znm56iirwq89"))))
(build-system cmake-build-system)
(native-inputs
- `(("gcc" ,gcc-9)))
+ (list gcc-9))
(synopsis "C++17 header only library for compile time reflection of enums")
(description "Magic Enum offers static reflection of enums, with
conversions to and from strings, iteration and related functionality.")
@@ -1080,8 +1081,7 @@ conversions to and from strings, iteration and related functionality.")
(("^ PROPERTIES FOLDER \"Extern\"\\)") ""))
#t)))))
(native-inputs
- `(("doxygen" ,doxygen)
- ("googletest" ,googletest)))
+ (list doxygen googletest))
(synopsis "Command line parser for C++11")
(description
"CLI11 is a command line parser for C++11 and beyond that provides a rich
@@ -1107,7 +1107,7 @@ feature set with a simple and intuitive interface.")
'(#:configure-flags
'("-DCAF_ENABLE_EXAMPLES=OFF")))
(inputs
- `(("openssl" ,openssl)))
+ (list openssl))
(synopsis "C++ implementation of the actor model")
(description "The C++ Actor Framework (CAF) offers a high-level C++17
programming environment using the actor model for concurrent, distributed
@@ -1164,9 +1164,7 @@ output randomness while retaining speed, simplicity, and conciseness.")
(replace 'bootstrap
(lambda _ (invoke "sh" "bootstrap" "--noconfigure"))))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
+ (list autoconf automake libtool))
(home-page "https://madmurphy.github.io/libconfini/html/index.html")
(synopsis "INI file parser")
(description "@code{libconfini} is an INI file parser library written in
@@ -1203,8 +1201,8 @@ almost every type of file containing key/value pairs.")
;;"--with-external-boost"
"--with-external-expat")))
(inputs
- `(;;("boost ,boost)
- ("expat" ,expat)))
+ (list ;;("boost ,boost)
+ expat))
(home-page "https://www.codesynthesis.com/projects/libcutl/")
(synopsis "C++ utility library with generic and independent components")
(description "libcutl is a C++ utility library. It contains a collection
@@ -1249,7 +1247,7 @@ pointers, containers, compiler building blocks, etc.")
#:include-regexp ("\\.so$")))
args))))))
(native-inputs
- `(("build" ,build)))
+ (list build))
(inputs
`(("libcutl" ,libcutl)
("libxerces-c" ,xerces-c)))
@@ -1297,9 +1295,9 @@ and a traversal mechanism.")
(string-append "edge_dispatcher::" all)))))
(delete 'configure))))
(native-inputs
- `(("build" ,build)))
+ (list build))
(inputs
- `(("libcutl" ,libcutl)))
+ (list libcutl))
(synopsis "C++ Command Line Interface (CLI) definition language")
(description "@code{cli} is a domain-specific language (DSL) for defining
command line interfaces of C++ programs. It allows you to describe the
@@ -1340,16 +1338,13 @@ documentation.")
,version)))))
(delete 'configure))))
(native-inputs
- `(("build" ,build)
- ("cli" ,cli)))
+ (list build cli))
(inputs
- `(("libcutl" ,libcutl)
- ("libnsl" ,libnsl)
- ("libxsd-frontend" ,libxsd-frontend)))
+ (list libcutl libnsl libxsd-frontend))
(propagated-inputs
;; The code XSD generates requires the following library at run time;
;; propagate it for convenience.
- `(("xerces-c" ,xerces-c)))
+ (list xerces-c))
(synopsis "XML Data Binding for C++")
(description "CodeSynthesis XSD (also known as libxsd or xsdcxx) is an XML
Schema to C++ data binding compiler. Provided with an XML instance
@@ -1393,10 +1388,9 @@ of reading and writing XML.")
`(#:configure-flags '("-DUSE_SYSTEM_GTEST=ON" "-DUSE_SYSTEM_JSON=ON"
"-DBUILD_STATIC_LIBS=OFF")))
(native-inputs
- `(("googletest" ,googletest)
- ("pkg-config" ,pkg-config)))
+ (list googletest pkg-config))
(inputs
- `(("json-modern-cxx" ,json-modern-cxx)))
+ (list json-modern-cxx))
(home-page "https://jsonnet.org/")
(synopsis "Data templating language")
(description "Jsonnet is a templating language extending JSON