summaryrefslogtreecommitdiff
path: root/gnu/packages/containers.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/containers.scm')
-rw-r--r--gnu/packages/containers.scm36
1 files changed, 20 insertions, 16 deletions
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 9a567f9f62..c978be75ff 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021 Timmy Douglas <mail@timmydouglas.com>
+;;; Copyright © 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -17,6 +18,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages containers)
+ #:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (guix packages)
@@ -105,7 +107,7 @@ Container Runtime fully written in C.")
(define-public conmon
(package
(name "conmon")
- (version "2.0.30")
+ (version "2.0.31")
(source
(origin
(method git-fetch)
@@ -113,24 +115,26 @@ Container Runtime fully written in C.")
(url "https://github.com/containers/conmon")
(commit (string-append "v" version))))
(sha256
- (base32 "1sxpbm01g4xak4kqwvk45gmzr6n9bjzlfp1j85wyz8rj2hg2x4rm"))
+ (base32 "1cxklcihb2i4ywli0fxafkp2gi1x831r37z7spnigaj6pzj1517w"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list ,(string-append "CC=" (cc-for-target))
- (string-append "PREFIX=" %output))
- ;; XXX: uses `go get` to download 50 packages, runs a ginkgo test suite
- ;; then tries to download busybox and use a systemd logging library
- ;; see also https://github.com/containers/conmon/blob/main/nix/derivation.nix
- #:tests? #f
- #:test-target "test"
- #:phases (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'set-env
- (lambda* (#:key inputs #:allow-other-keys)
- ;; when running go, things fail because
- ;; HOME=/homeless-shelter.
- (setenv "HOME" "/tmp"))))))
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ ;; XXX: uses `go get` to download 50 packages, runs a ginkgo test suite
+ ;; then tries to download busybox and use a systemd logging library
+ ;; see also https://github.com/containers/conmon/blob/main/nix/derivation.nix
+ #:tests? #f
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'set-env
+ (lambda _
+ ;; when running go, things fail because
+ ;; HOME=/homeless-shelter.
+ (setenv "HOME" "/tmp"))))))
(inputs
(list crun
glib