summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm142
1 files changed, 89 insertions, 53 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 44d1fd4bb5..e8a50c676c 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -133,10 +133,7 @@ in compression.")
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'enter-source
- (lambda _ (chdir "contrib/minizip") #t))
- (add-after 'enter-source 'autoreconf
- (lambda _
- (invoke "autoreconf" "-vif"))))))
+ (lambda _ (chdir "contrib/minizip") #t)))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -188,12 +185,7 @@ utility. Instead of being written in Java, FastJar is written in C.")
"02cihzl77ia0dcz7z2cga2412vyhhs5pa2355q4wpwbyga2lrwjh"))
(patches (search-patches "libtar-CVE-2013-4420.patch"))))
(build-system gnu-build-system)
- (arguments
- `(#:tests? #f ;no "check" target
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'autoconf
- (lambda _ (invoke "sh" "autoreconf" "-vfi"))))))
+ (arguments `(#:tests? #f)) ; no "check" target
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -363,7 +355,20 @@ decompression.")
version ".tar.gz"))
(sha256
(base32
- "1sahaqc5bw4i0iyri05syfza4ncf5cml89an033fspn97klmxis6"))))
+ "1sahaqc5bw4i0iyri05syfza4ncf5cml89an033fspn97klmxis6"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* (find-files "lib" "\\.c$")
+ (("#if defined _IO_ftrylockfile")
+ "#if defined _IO_EOF_SEEN"))
+ (substitute* "lib/stdio-impl.h"
+ (("^/\\* BSD stdio derived implementations")
+ (string-append "#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN\n"
+ "# define _IO_IN_BACKUP 0x100\n"
+ "#endif\n\n"
+ "/* BSD stdio derived implementations")))
+ #t))))
(build-system gnu-build-system)
(synopsis "Parallel bzip2 compression utility")
(description
@@ -585,22 +590,19 @@ decompressors when faced with corrupted input.")
(sha256
(base32
"16isapn8f39lnffc3dp4dan05b7x6mnc76v6q5nn8ysxvvvwy19b"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Adjust the bundled gnulib to work with glibc 2.28. See e.g.
- ;; "m4-gnulib-libio.patch". This is a phase rather than patch
- ;; or snippet to work around <https://bugs.gnu.org/32347>.
- (substitute* (find-files "lib" "\\.c$")
- (("#if defined _IO_ftrylockfile")
- "#if defined _IO_EOF_SEEN"))
- (substitute* "lib/stdio-impl.h"
- (("^/\\* BSD stdio derived implementations")
- (string-append "#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN\n"
- "# define _IO_IN_BACKUP 0x100\n"
- "#endif\n\n"
- "/* BSD stdio derived implementations")))
- #t))))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* (find-files "lib" "\\.c$")
+ (("#if defined _IO_ftrylockfile")
+ "#if defined _IO_EOF_SEEN"))
+ (substitute* "lib/stdio-impl.h"
+ (("^/\\* BSD stdio derived implementations")
+ (string-append "#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN\n"
+ "# define _IO_IN_BACKUP 0x100\n"
+ "#endif\n\n"
+ "/* BSD stdio derived implementations")))
+ #t))))
(build-system gnu-build-system)
(inputs
`(("which" ,which)))
@@ -694,13 +696,13 @@ sfArk file format to the uncompressed sf2 format.")
(package
(name "libmspack")
(home-page "https://cabextract.org.uk/libmspack/")
- (version "0.7.1")
+ (version "0.9.1")
(source
(origin
(method url-fetch)
(uri (string-append home-page name "-" version "alpha.tar.gz"))
(sha256
- (base32 "0zn4vwzk5ankgd0l88cipan19pzbzv0sm3fba17lvqwka3dp1acp"))))
+ (base32 "0h1f5w8rjnq7dcqpqm1mpx5m8q80691kid6f7npqlqwqqzckd8v2"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--disable-static")))
@@ -758,7 +760,8 @@ INCLUDE = ~a/include
LIB = ~:*~a/lib
OLD_ZLIB = False
GZIP_OS_CODE = AUTO_DETECT"
- (assoc-ref inputs "zlib")))))))))
+ (assoc-ref inputs "zlib"))))
+ #t)))))
(home-page "https://metacpan.org/release/Compress-Raw-Zlib")
(synopsis "Low-level interface to zlib compression library")
(description "This module provides a Perl interface to the zlib
@@ -1082,13 +1085,13 @@ smaller than those produced by @code{Xdelta}.")
(package
(name "cabextract")
(home-page "https://cabextract.org.uk/")
- (version "1.7")
+ (version "1.9")
(source (origin
(method url-fetch)
(uri (string-append home-page name "-" version ".tar.gz"))
(sha256
(base32
- "1g86wmb8lkjiv2jarfz979ngbgg7d3si8x5il4g801604v406wi9"))
+ "1hf4zhjxfdgq9x172r5zfdnafma9q0zf7372syn8hcn7hcypkg0v"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1096,11 +1099,27 @@ smaller than those produced by @code{Xdelta}.")
(delete-file-recursively "mspack")
#t))))
(build-system gnu-build-system)
- (arguments '(#:configure-flags '("--with-external-libmspack")))
+ (arguments
+ '(#:configure-flags '("--with-external-libmspack")
+ #:phases
+ (modify-phases %standard-phases
+ ;; cabextract needs some of libmspack's header files.
+ ;; These are located in the "mspack" directory of libmspack.
+ (add-before 'build 'unpack-libmspack
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((dir-name "libmspack-src"))
+ (mkdir dir-name)
+ (invoke "tar" "-xvf" (assoc-ref inputs "libmspack-source")
+ "-C" dir-name "--strip-components" "1")
+ (rename-file (string-append dir-name "/mspack")
+ "mspack")
+ (delete-file-recursively dir-name)
+ #t))))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("libmspack" ,libmspack)))
+ `(("libmspack" ,libmspack)
+ ("libmspack-source" ,(package-source libmspack))))
(synopsis "Tool to unpack Cabinet archives")
(description "Extracts files out of Microsoft Cabinet (.cab) archives")
;; Some source files specify gpl2+, lgpl2+, however COPYING is gpl3.
@@ -1112,13 +1131,14 @@ smaller than those produced by @code{Xdelta}.")
(version "3.1.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/jmacd/xdelta/archive/v"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jmacd/xdelta.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "17g2pbbqy6h20qgdjq7ykib7kg5ajh8fwbsfgyjqg8pwg19wy5bm"))
- (file-name (string-append name "-" version ".tar.gz"))
+ "09mmsalc7dwlvgrda56s2k927rpl3a5dzfa88aslkqcjnr790wjy"))
(snippet
;; This file isn't freely distributable and has no effect on building.
'(begin
@@ -1132,9 +1152,7 @@ smaller than those produced by @code{Xdelta}.")
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'enter-build-directory
- (lambda _ (chdir "xdelta3") #t))
- (add-after 'enter-build-directory 'autoconf
- (lambda _ (invoke "autoreconf" "-vfi"))))))
+ (lambda _ (chdir "xdelta3") #t)))))
(home-page "http://xdelta.org")
(synopsis "Delta encoder for binary files")
(description "xdelta encodes only the differences between two binary files
@@ -1184,16 +1202,30 @@ well as bzip2.")
(define-public bitshuffle
(package
(name "bitshuffle")
- (version "0.3.4")
+ (version "0.3.5")
(source (origin
(method url-fetch)
(uri (pypi-uri "bitshuffle" version))
(sha256
(base32
- "0ydawb01ghsvmw0lraczhrgvkjj97bpg98f1qqs1cnfp953mdd5v"))))
+ "1823x61kyax4dc2hjmc1xraskxi1193y8lvxd03vqv029jrj8cjy"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove generated Cython files.
+ (delete-file "bitshuffle/h5.c")
+ (delete-file "bitshuffle/ext.c")
+ #t))))
(build-system python-build-system)
(arguments
- `(#:tests? #f)) ; fail: https://github.com/h5py/h5py/issues/769
+ `(#:tests? #f ; fail: https://github.com/h5py/h5py/issues/769
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'dont-build-native
+ (lambda _
+ (substitute* "setup.py"
+ (("'-march=native', ") ""))
+ #t)))))
(inputs
`(("numpy" ,python-numpy)
("h5py" ,python-h5py)
@@ -1329,7 +1361,8 @@ install: libbitshuffle.so
(add-after 'build-jni 'copy-jni
(lambda _
(copy-recursively "src/main/resources/org/xerial/snappy/native"
- "build/classes/org/xerial/snappy/native")))
+ "build/classes/org/xerial/snappy/native")
+ #t))
(add-before 'check 'fix-failing
(lambda _
(with-directory-excursion "src/test/java/org/xerial/snappy"
@@ -1447,7 +1480,8 @@ compressor/decompressor.")
class))
(invoke "ant" "compile-tests")
(test "org.iq80.snappy.SnappyFramedStreamTest")
- (test "org.iq80.snappy.SnappyStreamTest")))
+ (test "org.iq80.snappy.SnappyStreamTest")
+ #t))
(add-before 'build 'remove-hadoop-dependency
(lambda _
;; We don't have hadoop
@@ -1752,14 +1786,14 @@ or junctions, and always follows hard links.")
(define-public zstd
(package
(name "zstd")
- (version "1.3.6")
+ (version "1.3.7")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/facebook/zstd/releases/download/"
"v" version "/zstd-" version ".tar.gz"))
(sha256
- (base32 "1525b31jmbiczjj1n58nckdzky4cdnbwcsil3zgy4cx03v0a0cp8"))))
+ (base32 "0gapsdzqfsfqqddzv22592iwa0008xjyi15f06pfv9hcvwvg4xrj"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1802,7 +1836,7 @@ speed.")
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'enter-subdirectory
- (lambda _ (chdir "contrib/pzstd")))
+ (lambda _ (chdir "contrib/pzstd") #t))
(delete 'configure) ; no configure script
(add-before 'check 'compile-tests
(lambda* (#:key make-flags #:allow-other-keys)
@@ -2084,14 +2118,16 @@ type by using either Perl modules, or command-line tools on your system.")
(lambda _
;; Our build system enters the first directory in the archive, but
;; the package is not contained in a subdirectory
- (chdir "..")))
+ (chdir "..")
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
;; Do we want to install *Demo.jar?
(install-file "build/jar/xz.jar"
(string-append
(assoc-ref outputs "out")
- "/share/java/xz.jar")))))))
+ "/share/java/xz.jar"))
+ #t)))))
(native-inputs
`(("unzip" ,unzip)))
(home-page "https://tukaani.org")
@@ -2227,7 +2263,7 @@ single-member files which can't be decompressed in parallel.")
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ;; No tests available.
- (inputs `(("boost" ,boost)
+ (inputs `(("boost" ,boost-cxx14)
("libiconv" ,libiconv)
("xz" ,xz)))
(native-inputs `(("pkg-config" ,pkg-config)))