summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 45e149ff56..e3800d84a5 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2584,12 +2584,17 @@ exec " gcc "/bin/" program
;; The build system assumes we have done a mistake when time_t is 32-bit
;; on a 64-bit system. Ignore that for our bootstrap toolchain.
- ,@(if (target-64bit?)
- (substitute-keyword-arguments (package-arguments findutils)
- ((#:configure-flags flags ''())
- `(cons "TIME_T_32_BIT_OK=yes"
- ,flags)))
- (package-arguments findutils))))))
+ ,@(substitute-keyword-arguments (package-arguments findutils)
+ ((#:configure-flags flags ''())
+ `(append
+ ,(if (target-64bit?)
+ ''("TIME_T_32_BIT_OK=yes")
+ ''())
+ ,(match (%current-system)
+ ((or "arm-linux" "aarch64-linux")
+ ''("--disable-dependency-tracking"))
+ (_ ''()))
+ ,flags)))))))
(define file
(package