summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 7186cf98df..95f884b36d 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -164,6 +164,18 @@ and workspaces that can be used in the compiler environment of your choice.")
license:expat ; cmjsoncpp is dual MIT/public domain
license:public-domain)))) ; cmlibarchive/archive_getdate.c
+(define-public cmake/fixed
+ ;; This is a variant of CMake that fixes X.509 certificate lookup:
+ ;; <https://issues.guix.gnu.org/issue/37371>.
+ (package
+ (inherit cmake)
+ (version (string-append (package-version cmake) "-1"))
+ (source (origin
+ (inherit (package-source cmake))
+ (patches
+ (append (search-patches "cmake-curl-certificates.patch")
+ (origin-patches (package-source cmake))))))))
+
(define-public emacs-cmake-mode
(package
(inherit cmake)