summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm29
1 files changed, 27 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c214f8bf8e..4578961acc 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -273,13 +273,13 @@ format.")
(define-public cppcheck
(package
(name "cppcheck")
- (version "1.82")
+ (version "1.83")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/danmar/cppcheck/archive/"
version ".tar.gz"))
(sha256
- (base32 "0zywpd9hbsx23aj33pk5mbr0fz1ijhqzxlnqgwjfwgg6g2k48i2j"))
+ (base32 "15ghxwmyy09cd9mi008k4jn09c441j86qyaa4dz0is7f5dv5cdkx"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system cmake-build-system)
(home-page "http://cppcheck.sourceforge.net")
@@ -2025,3 +2025,28 @@ retried.")
(define-public python2-pyhamcrest
(package-with-python2 python-pyhamcrest))
+
+(define-public unittest-cpp
+ (package
+ (name "unittest-cpp")
+ (version "2.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/unittest-cpp/unittest-cpp/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1fgmna2la7z4pwwy2gd10gpgi2q1fk89npjfvkmzvhkxhyc231bl"))))
+ (arguments
+ `(#:tests? #f)) ; It's run after build automatically.
+ (build-system cmake-build-system)
+ (home-page "https://github.com/unittest-cpp/unittest-cpp")
+ (synopsis "Lightweight unit testing framework for C++")
+ (description "UnitTest++ is a lightweight unit testing framework for C++.
+It was designed to do test-driven development on a wide variety of platforms.
+Simplicity, portability, speed, and small footprint are all very important
+aspects of UnitTest++. UnitTest++ is mostly standard C++ and makes minimal use
+of advanced library and language features, which means it should be easily
+portable to just about any platform.")
+ (license license:expat)))