summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 4e82da869e..739870dc77 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -431,6 +431,7 @@ a multi-paradigm automated test framework for C++ and Objective-C.")
(uri (git-reference
(url "git://git.liw.fi/cmdtest/")
(commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
"1yhcwsqcpckkq5kw3h07k0xg6infyiyzq9ni3nqphrzxis7hxjf1"))))
@@ -697,8 +698,8 @@ generation.")
(license license:bsd-3)))
(define-public googletest-1.8
- (package/inherit
- googletest
+ (package
+ (inherit googletest)
(version "1.8.1")
(source (origin
(method git-fetch)
@@ -1144,8 +1145,8 @@ contacting the real http server.")
;; python-bleach 3.1.0 requires this ancient version of pytest-runner.
;; Remove once no longer needed.
(define-public python-pytest-runner-2
- (package/inherit
- python-pytest-runner
+ (package
+ (inherit python-pytest-runner)
(version "2.12.2")
(source (origin
(method url-fetch)