summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm66
1 files changed, 27 insertions, 39 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 41946f4169..6428e86e70 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -183,7 +184,7 @@ compiler while still keeping it small, simple, fast and understandable.")
(define-public libbytesize
(package
(name "libbytesize")
- (version "1.4")
+ (version "2.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -191,52 +192,17 @@ compiler while still keeping it small, simple, fast and understandable.")
"download/" version "/libbytesize-" version ".tar.gz"))
(sha256
(base32
- "0bbqzln1nhjxl71aydq9k4jg3hvki9lqsb4w10s1i27jgibxqkdv"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; This Makefile hard-codes MSGMERGE et al. instead of
- ;; honoring what 'configure' detected. Fix that.
- (substitute* "po/Makefile.in"
- (("^MSGMERGE = msgmerge")
- "MSGMERGE = @MSGMERGE@\n"))
- #t))))
+ "1bpz9cpb8s47kqplkkiz6ryfahas2ma95g9rh2axnfjp6w1d9ixc"))))
(build-system gnu-build-system)
(arguments
- ;; When running "make", the POT files are built with the build time as
- ;; their "POT-Creation-Date". Later on, "make" notices that .pot
- ;; files were updated and goes on to run "msgmerge"; as a result, the
- ;; non-deterministic POT-Creation-Date finds its way into .po files,
- ;; and then in .gmo files. To avoid that, simply make sure 'msgmerge'
- ;; never runs. See <https://bugs.debian.org/792687>.
- '(#:configure-flags '("ac_cv_path_MSGMERGE=true")
-
- #:phases (modify-phases %standard-phases
- (add-after 'configure 'create-merged-po-files
- (lambda _
- ;; Create "merged PO" (.mpo) files so that 'msgmerge'
- ;; doesn't need to run.
- (for-each (lambda (po-file)
- (let ((merged-po
- (string-append (dirname po-file) "/"
- (basename po-file
- ".po")
- ".mpo")))
- (copy-file po-file merged-po)))
- (find-files "po" "\\.po$"))
- #t)))
-
- ;; One test fails because busctl (systemd only?) and python2-pocketlint
- ;; are missing. Should we fix it, we would need the "python-2" ,
- ;; "python2-polib" and "python2-six" native-inputs.
- #:tests? #f))
+ `(#:tests? #f))
(native-inputs
`(("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)
("python" ,python)))
(inputs
`(("mpfr" ,mpfr)
- ("pcre" ,pcre)))
+ ("pcre2" ,pcre2)))
(home-page "https://github.com/storaged-project/libbytesize")
(synopsis "Tiny C library for working with arbitrary big sizes in bytes")
(description
@@ -316,3 +282,25 @@ Its three main components are:
"The purpose of libfixposix is to offer replacements for parts of POSIX
whose behaviour is inconsistent across *NIX flavours.")
(license license:boost1.0)))
+
+(define-public libhx
+ (package
+ (name "libhx")
+ (version "3.24")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/libhx/libHX/"
+ "libHX-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0i8v2464p830c15myknvvs6bhxaf663lrqgga95l94ygfynkw6x5"))))
+ (build-system gnu-build-system)
+ (home-page "http://libhx.sourceforge.net")
+ (synopsis "C library with common data structures and functions")
+ (description
+ "This is a C library (with some C++ bindings available) that provides data
+structures and functions commonly needed, such as maps, deques, linked lists,
+string formatting and autoresizing, option and config file parsing, type
+checking casts and more.")
+ (license license:lgpl2.1+)))