summaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 255141ae87..c78aaa33d0 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -53,7 +53,9 @@
%bootstrap-glibc
%bootstrap-inputs
%bootstrap-mescc-tools
- %bootstrap-mes))
+ %bootstrap-mes
+
+ %bootstrap-inputs-for-tests))
;;; Commentary:
;;;
@@ -809,4 +811,14 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
;; In gnu-build-system.scm, we rely on the availability of Bash.
("bash" ,%bootstrap-coreutils&co)))
+(define %bootstrap-inputs-for-tests
+ ;; These are bootstrap inputs that are cheap to produce (no compilation
+ ;; needed) and that are meant to be used for testing. (These are those we
+ ;; used before the Mes-based reduced bootstrap.)
+ `(("libc" ,%bootstrap-glibc)
+ ("gcc" ,%bootstrap-gcc)
+ ("binutils" ,%bootstrap-binutils)
+ ("coreutils&co" ,%bootstrap-coreutils&co)
+ ("bash" ,%bootstrap-coreutils&co)))
+
;;; bootstrap.scm ends here