summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm32
1 files changed, 25 insertions, 7 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 5bd784f73c..b0617f452a 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2016, 2017 David Craven <david@craven.ch>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 nee <nee@cock.li>
;;;
;;; This file is part of GNU Guix.
@@ -624,7 +624,25 @@ board-independent tools.")))
(make-u-boot-package "mx6cuboxi" "arm-linux-gnueabihf"))
(define-public u-boot-novena
- (make-u-boot-package "novena" "arm-linux-gnueabihf"))
+ (let ((base (make-u-boot-package "novena" "arm-linux-gnueabihf")))
+ (package
+ (inherit base)
+ (description "U-Boot is a bootloader used mostly for ARM boards. It
+also initializes the boards (RAM etc).
+
+This U-Boot is built for Novena. Be advised that this version, contrary
+to Novena upstream, does not load u-boot.img from the first patition.")
+ (arguments
+ (substitute-keyword-arguments (package-arguments base)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'patch-novena-defconfig
+ ;; Patch configuration to disable loading u-boot.img from FAT partition,
+ ;; allowing it to be installed at a device offset.
+ (lambda _
+ (substitute* "configs/novena_defconfig"
+ (("CONFIG_SPL_FAT_SUPPORT=y") "# CONFIG_SPL_FAT_SUPPORT is not set"))
+ #t)))))))))
(define-public u-boot-cubieboard
(make-u-boot-package "Cubieboard" "arm-linux-gnueabihf"))
@@ -755,7 +773,7 @@ tools, and more.")
(define-public os-prober
(package
(name "os-prober")
- (version "1.76")
+ (version "1.77")
(source
(origin
(method url-fetch)
@@ -763,15 +781,15 @@ tools, and more.")
version ".tar.xz"))
(sha256
(base32
- "1vb45i76bqivlghrq7m3n07qfmmq4wxrkplqx8gywj011rhq19fk"))))
+ "0pvhrw4h05n21zw7ig3a3bi8aqdh6zxs0x1znz4g7vhspsps93ld"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
(guix build utils)
- (ice-9 regex) ; for string-match
- (srfi srfi-26)) ; for cut
+ (ice-9 regex) ; for string-match
+ (srfi srfi-26)) ; for cut
#:make-flags (list "CC=gcc")
- #:tests? #f ; no tests
+ #:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
(replace 'configure