summaryrefslogtreecommitdiff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 6b8eebcecb..a2253a9efc 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -69,6 +69,11 @@
#:make-flags
(list "threading=multi" "link=shared"
+ ;; XXX: Disable installation of Boosts modular CMake config scripts
+ ;; which conflicts in 1.70.0 with the ones provided by CMake.
+ ;; See <https://bugs.gnu.org/36721>.
+ "--no-cmake-config"
+
;; Set the RUNPATH to $libdir so that the libs find each other.
(string-append "linkflags=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib"))