summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm106
1 files changed, 47 insertions, 59 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index e014136c44..0dcb1ee991 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018 Nam Nguyen <namn@berkeley.edu>
-;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
@@ -93,6 +93,10 @@
(list (string-append "--localedir="
(assoc-ref %outputs "gui")
"/share/locale"))
+ ;; Some tests segfault when using libevent 2.12 without internet
+ ;; connection. This has been reported mainstream but not fixed yet:
+ ;; https://github.com/transmission/transmission/issues/1437.
+ #:tests? #f
#:glib-or-gtk-wrap-excluded-outputs '("out")
#:phases
(modify-phases %standard-phases
@@ -118,14 +122,9 @@
(string-append gui "/share/man/man1/transmission-gtk.1"))
#t))))))
(inputs
- `(("libevent" ,libevent)
- ("curl" ,curl)
- ("openssl" ,openssl)
- ("zlib" ,zlib)
- ("gtk+" ,gtk+)))
+ (list libevent curl openssl zlib gtk+))
(native-inputs
- `(("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
+ (list intltool pkg-config))
(home-page "https://transmissionbt.com/")
(synopsis "Fast and easy BitTorrent client")
(description
@@ -147,26 +146,21 @@ DHT, µTP, PEX and Magnet Links.")
(define-public transmission-remote-gtk
(package
(name "transmission-remote-gtk")
- (version "1.4.1")
+ (version "1.4.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/transmission-remote-gtk/"
"transmission-remote-gtk/releases/download/"
version "/transmission-remote-gtk-" version
- ".tar.xz"))
- (patches (search-patches "transmission-remote-gtk-fix-appstream.patch"))
+ ".tar.gz"))
(sha256
- (base32 "1aqjl5rgamgcgqvcldd1gzyfh2xci0m7070924d6vz2qln0q75sr"))))
+ (base32 "0qz9wi70qc6vgnaymivc3xz6y86c9hglk6wjv3snnqxpxmp9saay"))))
(build-system gnu-build-system)
(native-inputs
- `(("gettext" ,gnu-gettext)
- ("pkg-config" ,pkg-config)))
+ (list gnu-gettext pkg-config))
(inputs
- `(("appstream-glib" ,appstream-glib)
- ("curl" ,curl)
- ("gtk+" ,gtk+)
- ("json-glib" ,json-glib)))
+ (list appstream-glib curl gtk+ json-glib))
(synopsis "Gtk frontend to the Transmission daemon")
(description "transmission-remote-gtk is a GTK client for remote management
of the Transmission BitTorrent client, using its HTTP RPC protocol.")
@@ -186,10 +180,8 @@ of the Transmission BitTorrent client, using its HTTP RPC protocol.")
(base32
"10z9i1rc41cmmi7nx8k7k1agsx6afv09g9cl7g9zr35fyhl5l4gd"))))
(build-system gnu-build-system)
- (inputs `(("openssl" ,openssl)
- ("zlib" ,zlib)))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("cppunit" ,cppunit)))
+ (inputs (list openssl zlib))
+ (native-inputs (list pkg-config cppunit))
(synopsis "BitTorrent library of rtorrent")
(description
"LibTorrent is a BitTorrent library used by and developed in parallel
@@ -211,14 +203,13 @@ speed and efficiency.")
(base32
"1bs2fnf4q7mlhkhzp3i1v052v9xn8qa7g845pk9ia8hlpw207pwy"))))
(build-system gnu-build-system)
- (inputs `(("libtorrent" ,libtorrent)
- ("ncurses" ,ncurses)
- ("curl" ,curl)
- ("cyrus-sasl" ,cyrus-sasl)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("cppunit" ,cppunit)))
+ (inputs (list libtorrent
+ ncurses
+ curl
+ cyrus-sasl
+ openssl
+ zlib))
+ (native-inputs (list pkg-config cppunit))
(synopsis "BitTorrent client with ncurses interface")
(description
"rTorrent is a BitTorrent client with an ncurses interface. It supports
@@ -252,7 +243,7 @@ XML-RPC over SCGI.")
(delete 'configure)
(delete 'build))))
(inputs
- `(("python" ,python)))
+ (list python))
(synopsis "Console client for the Transmission BitTorrent daemon")
(description "Tremc is a console client, with a curses interface, for the
Transmission BitTorrent daemon.")
@@ -331,17 +322,17 @@ maintained upstream.")
(string-append "// " text)))
#t)))))
(native-inputs
- `(("cppunit" ,cppunit) ; for the tests
- ("pkg-config" ,pkg-config)))
+ (list cppunit ; for the tests
+ pkg-config))
(inputs
- `(("c-ares" ,c-ares)
- ("gnutls" ,gnutls)
- ("gmp" ,gmp)
- ("libssh2" ,libssh2)
- ("libxml2" ,libxml2)
- ("nettle" ,nettle)
- ("sqlite" ,sqlite)
- ("zlib" ,zlib)))
+ (list c-ares
+ gnutls
+ gmp
+ libssh2
+ libxml2
+ nettle
+ sqlite
+ zlib))
(home-page "https://aria2.github.io/")
(synopsis "Utility for parallel downloading files")
(description
@@ -363,18 +354,19 @@ Aria2 can be manipulated via built-in JSON-RPC and XML-RPC interfaces.")
(sha256
(base32 "0dlrjhnm1pg2vwmp7nl2xv1aia5hyirb3021rl46x859k63zap24"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("CFLAGS=-fcommon")))
(inputs
- `(("curl" ,curl)
- ("gtk+" ,gtk+)
- ("glib" ,glib)
- ("gnutls" ,gnutls)
- ("gstreamer" ,gstreamer)
- ("libgcrypt" ,libgcrypt)
- ("libnotify" ,libnotify)
- ("openssl" ,openssl)))
+ (list curl
+ gtk+
+ glib
+ gnutls
+ gstreamer
+ libgcrypt
+ libnotify
+ openssl))
(native-inputs
- `(("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
+ (list intltool pkg-config))
(home-page "https://ugetdm.com/")
(synopsis "Universal download manager with GTK+ interface")
(description
@@ -434,8 +426,7 @@ and will take advantage of multiple processor cores where possible.")
(base32 "0gwm4w7337ykh5lfnspapnnz6a35g7yay3wnj126s8s5kcsvy9wy"))))
(build-system cmake-build-system)
(arguments
- `(#:cmake ,cmake ;3.17 or later
- #:configure-flags '("-Dpython-bindings=ON"
+ `(#:configure-flags '("-Dpython-bindings=ON"
"-Dbuild_tests=ON")
#:phases
(modify-phases %standard-phases
@@ -455,8 +446,7 @@ and will take advantage of multiple processor cores where possible.")
"-j" (if parallel-tests?
(number->string (parallel-job-count))
"1")))))))))
- (inputs `(("boost" ,boost)
- ("openssl" ,openssl)))
+ (inputs (list boost openssl))
(native-inputs `(("libfaketime" ,libfaketime)
("python" ,python-wrapper)
("pkg-config" ,pkg-config)))
@@ -502,8 +492,7 @@ desktops.")
(wrap-qt-program "qbittorrent" #:output out #:inputs inputs))
#t)))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("qttools" ,qttools)))
+ (list pkg-config qttools))
(inputs
`(("boost" ,boost)
("libtorrent-rasterbar" ,libtorrent-rasterbar)
@@ -556,8 +545,7 @@ features.")
("python-twisted" ,python-twisted)
("python-zope-interface" ,python-zope-interface)))
(native-inputs
- `(("intltool" ,intltool)
- ("python-wheel" ,python-wheel)))
+ (list intltool python-wheel))
;; TODO: Enable tests.
;; After "pytest-twisted" is packaged, HOME is set, and an X server is
;; started, some of the tests still fail. There are likely some tests