summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm41
1 files changed, 40 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 239a8c13df..1d8397c1aa 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11094,6 +11094,15 @@ expression report comparing samples in an easily configurable manner.")
(modify-phases %standard-phases
(add-before 'bootstrap 'autoreconf
(lambda _
+ ;; This was fixed in commit
+ ;; 0b1c9f7f2e4d0ff601f1de95ab8b2953f4d5dbc7, but there is no
+ ;; release with this fix.
+ (call-with-output-file "VERSION"
+ (lambda (port) (display ,version port)))
+ ;; See https://github.com/BIMSBbioinfo/pigx_chipseq/issues/176
+ (substitute* "m4/ax_r_package.m4"
+ (("if\\(is.na\\(packageDescription\\(\"PKG\"\\)\\)\\)")
+ "if(system.file(package=\"PKG\") == \"\")"))
(invoke "autoreconf" "-vif")))
(add-before 'configure 'set-PYTHONPATH
(lambda _
@@ -11182,6 +11191,15 @@ in an easily configurable manner.")
(modify-phases %standard-phases
(add-before 'bootstrap 'autoreconf
(lambda _
+ ;; This was fixed in commit
+ ;; d56ac732524da659afbbb0972f7a87fa178ae58e, but there is no
+ ;; release with this fix.
+ (call-with-output-file "VERSION"
+ (lambda (port) (display ,version port)))
+ ;; https://github.com/BIMSBbioinfo/pigx_bsseq/issues/181
+ (substitute* "m4/ax_r_package.m4"
+ (("if\\(is.na\\(packageDescription\\(\"PKG\"\\)\\)\\)")
+ "if(system.file(package=\"PKG\") == \"\")"))
(invoke "autoreconf" "-vif")))
(add-before 'configure 'set-PYTHONPATH
(lambda _
@@ -11249,8 +11267,20 @@ methylation and segmentation.")
"1lc42hl8mz95kilh0z39s3wnv092mhm6vl2i394n0yfvdzk4f885"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
+ (add-before 'bootstrap 'autoreconf
+ (lambda _
+ ;; This was fixed in commit
+ ;; c4ac067438ae9312b5786a72e2bfb3d795e3ec8a, but there is no
+ ;; release with this fix.
+ (call-with-output-file "VERSION"
+ (lambda (port) (display ,version port)))
+ ;; https://github.com/BIMSBbioinfo/pigx_scrnaseq/issues/59
+ (substitute* "m4/ax_r_package.m4"
+ (("if\\(is.na\\(packageDescription\\(\"PKG\"\\)\\)\\)")
+ "if(system.file(package=\"PKG\") == \"\")"))
+ (invoke "autoreconf" "-vif")))
(add-before 'configure 'set-additional-environment-variables
(lambda _
;; Needed because of loompy
@@ -11299,6 +11329,8 @@ methylation and segmentation.")
r-singlecellexperiment
r-stringr
r-yaml))
+ (native-inputs
+ (list autoconf automake))
(home-page "https://bioinformatics.mdc-berlin.de/pigx/")
(synopsis "Analysis pipeline for single-cell RNA sequencing experiments")
(description
@@ -11327,6 +11359,13 @@ based methods.")
`(#:tests? #f ;requires huge kraken database
#:phases
(modify-phases %standard-phases
+ (add-before 'bootstrap 'autoreconf
+ (lambda _
+ ;; https://github.com/BIMSBbioinfo/pigx_sars-cov-2/issues/123
+ (substitute* "m4/ax_r_package.m4"
+ (("if\\(is.na\\(packageDescription\\(\"PKG\"\\)\\)\\)")
+ "if(system.file(package=\"PKG\") == \"\")"))
+ (invoke "autoreconf" "-vif")))
(add-before 'configure 'set-PYTHONPATH
(lambda _
(setenv "PYTHONPATH" (getenv "GUIX_PYTHONPATH")))))))