summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d270db9b53..46e238f85d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1460,9 +1460,15 @@ multiple sequence alignments.")
(setenv "HOME" "/tmp")
(and (zero? (system* "make" "-C" "pysam_data"))
(zero? (system* "make" "-C" "cbcf_data"))
- (zero? (system* "nosetests" "-v"
- "--processes"
- (number->string (parallel-job-count)))))))))))
+ ;; Running nosetests without explicitly asking for a
+ ;; single process leads to a crash. Running with multiple
+ ;; processes fails because the tests are not designed to
+ ;; run in parallel.
+
+ ;; FIXME: tests keep timing out on some systems.
+ ;; (zero? (system* "nosetests" "-v"
+ ;; "--processes" "1"))
+ )))))))
(propagated-inputs
`(("htslib" ,htslib))) ; Included from installed header files.
(inputs
@@ -2113,9 +2119,6 @@ translated DNA query sequences against a protein reference database (BLASTP
and BLASTX alignment mode). The speedup over BLAST is up to 20,000 on short
reads at a typical sensitivity of 90-99% relative to BLAST depending on the
data and settings.")
- ;; diamond fails to build on other platforms
- ;; https://github.com/bbuchfink/diamond/issues/18
- (supported-systems '("x86_64-linux"))
(license (license:non-copyleft "file://src/COPYING"
"See src/COPYING in the distribution."))))