summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm59
1 files changed, 55 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 04ed769cd8..f5e7285193 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1482,7 +1482,7 @@ identify enrichments with functional annotations of the genome.")
(define-public diamond
(package
(name "diamond")
- (version "0.8.5")
+ (version "0.8.7")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1491,7 +1491,7 @@ identify enrichments with functional annotations of the genome.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "18zx8k3axnsrg016kikl8xs1ifnjmj36dk1sv3fq1jgpg9j9584b"))))
+ "15r7gcrqc4pv5d4kvv530zc3xnni92c74y63zrxzidriss7591yx"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; no "check" target
@@ -3815,10 +3815,61 @@ data in the form of VCF files.")
;; at https://vcftools.github.io/license.html
(license license:lgpl3)))
+(define-public r-vegan
+ (package
+ (name "r-vegan")
+ (version "2.4-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "vegan" version))
+ (sha256
+ (base32
+ "10cygzkyg2m0y054ygivqxrkvqz792qsg6bmbdfzaqq37qv4wc7z"))))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'revert-test-deletion
+ ;; The distributed sources do not include tests with the CRAN
+ ;; package. Here we revert the commit
+ ;; `591d0e8ba1deaaf82445474ec6619c0b43db4e63' which deletes these
+ ;; tests. There are plans to not delete tests in future as
+ ;; documented at https://github.com/vegandevs/vegan/issues/181.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (zero?
+ (system* "patch" "-R" "-p1" "-i"
+ (assoc-ref inputs "r-vegan-delete-tests-patch"))))))))
+ (native-inputs
+ `(("gfortran" ,gfortran)
+ ("r-knitr" ,r-knitr)
+ ("r-vegan-delete-tests-patch"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/vegandevs/vegan/commit/"
+ "591d0e8ba1deaaf82445474ec6619c0b43db4e63.patch"))
+ (sha256
+ (base32
+ "0b1bi7y4jjdl3ph721vm9apm51dr2z9piwvhy4355sf2b4kyyj5a"))))))
+ (propagated-inputs
+ `(("r-cluster" ,r-cluster)
+ ("r-lattice" ,r-lattice)
+ ("r-mgcv" ,r-mgcv)
+ ("r-permute" ,r-permute)))
+ (home-page "https://cran.r-project.org/web/packages/vegan")
+ (synopsis "Functions for community ecology")
+ (description
+ "The vegan package provides tools for descriptive community ecology. It
+has most basic functions of diversity analysis, community ordination and
+dissimilarity analysis. Most of its multivariate tools can be used for other
+data types as well.")
+ (license license:gpl2+)))
+
(define-public vsearch
(package
(name "vsearch")
- (version "1.11.1")
+ (version "2.0.0")
(source
(origin
(method url-fetch)
@@ -3828,7 +3879,7 @@ data in the form of VCF files.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1pdvm3znjgq3zryy240yj9gc0bf1z31k6vf9jxrxgdgkvzgw85c7"))
+ "1sd57abgx077icqrbj36jq9q7pdpzc6dbics2pn1555kisq2jhfh"))
(modules '((guix build utils)))
(snippet
'(begin