summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm101
1 files changed, 93 insertions, 8 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 00490dbcbb..91355f24e2 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8818,18 +8818,17 @@ replacement for strverscmp.")
(define-public multiqc
(package
(name "multiqc")
- (version "1.3")
+ (version "1.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "multiqc" version))
(sha256
(base32
- "0fx1sx53znbgzfhbbiyd8j6cg5llpcsl5q5c45jy2c81d12piqfd"))))
+ "0ihx4rzmsfphv4byn05qv6f1y95g2dxs6viwziipl4wjk96acgm8"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-enum34" ,python-enum34)
- ("python-jinja2" ,python-jinja2)
+ `(("python-jinja2" ,python-jinja2)
("python-simplejson" ,python-simplejson)
("python-pyyaml" ,python-pyyaml)
("python-click" ,python-click)
@@ -10627,6 +10626,67 @@ cell-specific biases, assignment of cell cycle phase, and detection of highly
variable and significantly correlated genes.")
(license license:gpl3)))
+(define-public r-delayedmatrixstats
+ (package
+ (name "r-delayedmatrixstats")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DelayedMatrixStats" version))
+ (sha256
+ (base32
+ "1nfdan0k2z4mynxyblsil0cjclsy63b0w9r1hczfk27i8hmxx13h"))))
+ (properties
+ `((upstream-name . "DelayedMatrixStats")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-delayedarray" ,r-delayedarray)
+ ("r-iranges" ,r-iranges)
+ ("r-matrix" ,r-matrix)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-s4vectors" ,r-s4vectors)))
+ (home-page "https://github.com/PeteHaitch/DelayedMatrixStats")
+ (synopsis "Functions that apply to rows and columns of DelayedMatrix objects")
+ (description
+ "This package provides a port of the @code{matrixStats} API for use with
+@code{DelayedMatrix} objects from the @code{DelayedArray} package. It
+contains high-performing functions operating on rows and columns of
+@code{DelayedMatrix} objects, e.g. @code{colMedians}, @code{rowMedians},
+@code{colRanks}, @code{rowRanks}, @code{colSds}, and @code{rowSds}. Functions
+are optimized per data type and for subsetted calculations such that both
+memory usage and processing time is minimized.")
+ (license license:expat)))
+
+(define-public r-dropbead
+ (let ((commit "cf0be5ae5302684bd03e78ab65b142900bbbb840")
+ (revision "1"))
+ (package
+ (name "r-dropbead")
+ (version (string-append "0-" revision "." (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rajewsky-lab/dropbead.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "1b2lphsc236s1rdzlijxg8yl1jnqpwcvj4x938r89rqpj93jb780"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-gridextra" ,r-gridextra)
+ ("r-gplots" ,r-gplots)
+ ("r-plyr" ,r-plyr)))
+ (home-page "https://github.com/rajewsky-lab/dropbead")
+ (synopsis "Basic exploration and analysis of Drop-seq data")
+ (description "This package offers a quick and straight-forward way to
+explore and perform basic analysis of single cell sequencing data coming from
+droplet sequencing. It has been particularly tailored for Drop-seq.")
+ (license license:gpl3))))
+
(define htslib-for-sambamba
(let ((commit "2f3c3ea7b301f9b45737a793c0b2dcf0240e5ee5"))
(package
@@ -10942,10 +11002,7 @@ programs for inferring phylogenies (evolutionary trees).")
(arguments
`(;; FIXME: Some tests fail because they produce warnings, others fail
;; because the PYTHONPATH does not include the modeller's directory.
- #:tests? #f
- ;; Do not place libraries in an architecture-specific directory.
- #:configure-flags
- (list "-DCMAKE_INSTALL_LIBDIR=lib")))
+ #:tests? #f))
(inputs
`(("boost" ,boost)
("gsl" ,gsl)
@@ -11800,3 +11857,31 @@ use of lightweight alignments (accurate but fast-to-compute proxies for
traditional read alignments) and massively-parallel stochastic collapsed
variational inference.")
(license license:gpl3+)))
+
+(define-public python-loompy
+ (package
+ (name "python-loompy")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "loompy" version))
+ (sha256
+ (base32
+ "1drgv8j1hxqzzpnfg272x9djb6j8qr798w1pc2x8ikmfgyd9gh51"))))
+ (build-system python-build-system)
+ ;; There are no tests
+ (arguments '(#:tests? #f))
+ (propagated-inputs
+ `(("python-h5py" ,python-h5py)
+ ("python-numpy" ,python-numpy)
+ ("python-scipy" ,python-scipy)
+ ("python-typing" ,python-typing)))
+ (home-page "https://github.com/linnarsson-lab/loompy")
+ (synopsis "Work with .loom files for single-cell RNA-seq data")
+ (description "The loom file format is an efficient format for very large
+omics datasets, consisting of a main matrix, optional additional layers, a
+variable number of row and column annotations. Loom also supports sparse
+graphs. This library makes it easy to work with @file{.loom} files for
+single-cell RNA-seq data.")
+ (license license:bsd-3)))