summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm37
1 files changed, 10 insertions, 27 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5412440fb1..08c5e78aff 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1109,9 +1109,6 @@ relying on a complex dependency tree.")
(build-system cmake-build-system)
(arguments
`(#:parallel-build? #f))
- (inputs
- `(("gcc" ,gcc-5))) ; Compilation of bpp-phyl fails with GCC 4.9 so we
- ; compile all of the bpp packages with GCC 5.
(home-page "http://biopp.univ-montp2.fr")
(synopsis "C++ libraries for Bioinformatics")
(description
@@ -1147,10 +1144,7 @@ providing them a set of re-usable tools.")
#:out-of-source? #f))
(inputs
`(("bpp-core" ,bpp-core)
- ("bpp-seq" ,bpp-seq)
- ;; GCC 4.8 fails due to an 'internal compiler error', so we use a more
- ;; modern GCC.
- ("gcc" ,gcc-5)))
+ ("bpp-seq" ,bpp-seq)))
(home-page "http://biopp.univ-montp2.fr")
(synopsis "Bio++ phylogenetic Library")
(description
@@ -1182,8 +1176,7 @@ library provides phylogenetics-related modules.")
#:tests? #f)) ; There are no tests.
(inputs
`(("bpp-core" ,bpp-core)
- ("bpp-seq" ,bpp-seq)
- ("gcc" ,gcc-5)))
+ ("bpp-seq" ,bpp-seq)))
(home-page "http://biopp.univ-montp2.fr")
(synopsis "Bio++ population genetics library")
(description
@@ -1216,8 +1209,7 @@ library provides population genetics-related modules.")
;; so the tests fail.
#:out-of-source? #f))
(inputs
- `(("bpp-core" ,bpp-core)
- ("gcc" ,gcc-5))) ; Use GCC 5 as per 'bpp-core'.
+ `(("bpp-core" ,bpp-core)))
(home-page "http://biopp.univ-montp2.fr")
(synopsis "Bio++ sequence library")
(description
@@ -1255,8 +1247,7 @@ library provides sequence-related modules.")
`(("bpp-core" ,bpp-core)
("bpp-seq" ,bpp-seq)
("bpp-phyl" ,bpp-phyl)
- ("bpp-phyl" ,bpp-popgen)
- ("gcc" ,gcc-5)))
+ ("bpp-phyl" ,bpp-popgen)))
(home-page "http://biopp.univ-montp2.fr")
(synopsis "Bioinformatics tools written with the Bio++ libraries")
(description
@@ -3260,9 +3251,7 @@ comment or quality sections.")
(lambda* (#:key inputs #:allow-other-keys)
;; Ensure that Eigen headers can be found
(setenv "CPLUS_INCLUDE_PATH"
- (string-append (getenv "CPLUS_INCLUDE_PATH")
- ":"
- (assoc-ref inputs "eigen")
+ (string-append (assoc-ref inputs "eigen")
"/include/eigen3"))
#t))
(add-before 'build 'bin-mkdir
@@ -11699,9 +11688,7 @@ bytes of memory space, where n is the length of the string.")
;; Ensure that Eigen headers can be found
(setenv "CPLUS_INCLUDE_PATH"
- (string-append (getenv "CPLUS_INCLUDE_PATH")
- ":"
- (assoc-ref inputs "eigen")
+ (string-append (assoc-ref inputs "eigen")
"/include/eigen3"))
#t)))))
(inputs
@@ -11880,14 +11867,11 @@ The following file formats are supported:
(("lib/libdivsufsort.a") "/lib/libdivsufsort.so"))
;; Ensure that all headers can be found
- (setenv "CPLUS_INCLUDE_PATH"
- (string-append (getenv "CPLUS_INCLUDE_PATH")
+ (setenv "CPATH"
+ (string-append (getenv "CPATH")
":"
(assoc-ref inputs "eigen")
"/include/eigen3"))
- (setenv "CPATH"
- (string-append (assoc-ref inputs "eigen")
- "/include/eigen3"))
#t))
;; CMAKE_INSTALL_PREFIX does not exist when the tests are
;; run. It only exists after the install phase.
@@ -13956,13 +13940,11 @@ datasets.")
("ghc-intervalmap" ,ghc-intervalmap)
("ghc-missingh" ,ghc-missingh)
("ghc-optparse-applicative" ,ghc-optparse-applicative)
- ("ghc-parsec" ,ghc-parsec)
("ghc-regex" ,ghc-regex)
("ghc-safe" ,ghc-safe)
("ghc-safeio" ,ghc-safeio)
("ghc-strict" ,ghc-strict)
("ghc-tar" ,ghc-tar)
- ("ghc-text" ,ghc-text)
("ghc-unliftio" ,ghc-unliftio)
("ghc-unliftio-core" ,ghc-unliftio-core)
("ghc-vector" ,ghc-vector)
@@ -14083,7 +14065,8 @@ choosing which reads pass the filter.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append (assoc-ref inputs "eigen")
- "/include/eigen3"))
+ "/include/eigen3:"
+ (or (getenv "CPATH") "")))
#t))
(delete 'configure)
(replace 'install