summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm259
1 files changed, 259 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 09581d9fde..76ff773ef1 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -23,6 +23,8 @@
#:use-module (guix download)
#:use-module (guix build-system r)
#:use-module (gnu packages)
+ #:use-module (gnu packages cran)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages statistics)
#:use-module (gnu packages bioinformatics))
@@ -70,3 +72,260 @@ the Human Protein Atlas project.")
customizable permutation tests to assess the association between genomic
region sets and other genomic features.")
(license license:artistic2.0)))
+
+(define-public r-diffbind
+ (package
+ (name "r-diffbind")
+ (version "2.6.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DiffBind" version))
+ (sha256
+ (base32
+ "1sm5h6nq77hjfis6kr1nqyizcxgfz87dgpqc4fxlfqkmsd9n3vkp"))))
+ (properties `((upstream-name . "DiffBind")))
+ (build-system r-build-system)
+ (inputs
+ `(("zlib" ,zlib)))
+ (propagated-inputs
+ `(("r-amap" ,r-amap)
+ ("r-biocparallel" ,r-biocparallel)
+ ("r-deseq2" ,r-deseq2)
+ ("r-dplyr" ,r-dplyr)
+ ("r-edger" ,r-edger)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-ggrepel" ,r-ggrepel)
+ ("r-gplots" ,r-gplots)
+ ("r-iranges" ,r-iranges)
+ ("r-lattice" ,r-lattice)
+ ("r-limma" ,r-limma)
+ ("r-locfit" ,r-locfit)
+ ("r-rcolorbrewer" , r-rcolorbrewer)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-systempiper" ,r-systempiper)
+ ("r-zlibbioc" ,r-zlibbioc)))
+ (home-page "http://bioconductor.org/packages/DiffBind")
+ (synopsis "Differential binding analysis of ChIP-Seq peak data")
+ (description
+ "This package computes differentially bound sites from multiple
+ChIP-seq experiments using affinity (quantitative) data. Also enables
+occupancy (overlap) analysis and plotting functions.")
+ (license license:artistic2.0)))
+
+(define-public r-ripseeker
+ (package
+ (name "r-ripseeker")
+ (version "1.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "RIPSeeker" version))
+ (sha256
+ (base32
+ "0bqkzwrncww7il36273chkd3gfxmii7p566ycki9qij419pwr35y"))))
+ (properties `((upstream-name . "RIPSeeker")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-s4vectors" ,r-s4vectors)
+ ("r-iranges" ,r-iranges)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-rtracklayer" ,r-rtracklayer)))
+ (home-page "http://bioconductor.org/packages/RIPSeeker")
+ (synopsis
+ "Identifying protein-associated transcripts from RIP-seq experiments")
+ (description
+ "This package infers and discriminates RIP peaks from RIP-seq alignments
+using two-state HMM with negative binomial emission probability. While
+RIPSeeker is specifically tailored for RIP-seq data analysis, it also provides
+a suite of bioinformatics tools integrated within this self-contained software
+package comprehensively addressing issues ranging from post-alignments
+processing to visualization and annotation.")
+ (license license:gpl2)))
+
+(define-public r-multtest
+ (package
+ (name "r-multtest")
+ (version "2.34.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "multtest" version))
+ (sha256
+ (base32
+ "0n11rd49xl2vn3ldmfips7d3yb70l8npjcqsxyswr9ypjhgzkv9j"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-survival" ,r-survival)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-biobase" ,r-biobase)
+ ("r-mass" ,r-mass)))
+ (home-page "http://bioconductor.org/packages/multtest")
+ (synopsis "Resampling-based multiple hypothesis testing")
+ (description
+ "This package can do non-parametric bootstrap and permutation
+resampling-based multiple testing procedures (including empirical Bayes
+methods) for controlling the family-wise error rate (FWER), generalized
+family-wise error rate (gFWER), tail probability of the proportion of
+false positives (TPPFP), and false discovery rate (FDR). Several choices
+of bootstrap-based null distribution are implemented (centered, centered
+and scaled, quantile-transformed). Single-step and step-wise methods are
+available. Tests based on a variety of T- and F-statistics (including
+T-statistics based on regression parameters from linear and survival models
+as well as those based on correlation parameters) are included. When probing
+hypotheses with T-statistics, users may also select a potentially faster null
+distribution which is multivariate normal with mean zero and variance
+covariance matrix derived from the vector influence function. Results are
+reported in terms of adjusted P-values, confidence regions and test statistic
+cutoffs. The procedures are directly applicable to identifying differentially
+expressed genes in DNA microarray experiments.")
+ (license license:lgpl3)))
+
+(define-public r-chippeakanno
+ (package
+ (name "r-chippeakanno")
+ (version "3.12.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ChIPpeakAnno" version))
+ (sha256
+ (base32
+ "1zab489d7a6bh6ylc68x6yn47gdkmr7p3677grx9l2qafrryjr04"))))
+ (properties `((upstream-name . "ChIPpeakAnno")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-go-db" ,r-go-db)
+ ("r-biomart" ,r-biomart)
+ ("r-bsgenome" ,r-bsgenome)
+ ("r-genomicfeatures" ,r-genomicfeatures)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-annotationdbi" ,r-annotationdbi)
+ ("r-limma" ,r-limma)
+ ("r-multtest" ,r-multtest)
+ ("r-rbgl" ,r-rbgl)
+ ("r-graph" ,r-graph)
+ ("r-biocinstaller" ,r-biocinstaller)
+ ("r-regioner" ,r-regioner)
+ ("r-dbi" ,r-dbi)
+ ("r-ensembldb" ,r-ensembldb)
+ ("r-biobase" ,r-biobase)
+ ("r-seqinr" ,r-seqinr)
+ ("r-idr" ,r-idr)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-venndiagram" ,r-venndiagram)))
+ (home-page "http://bioconductor.org/packages/ChIPpeakAnno")
+ (synopsis "Peaks annotation from ChIP-seq and ChIP-chip experiments")
+ (description
+ "The package includes functions to retrieve the sequences around the peak,
+obtain enriched Gene Ontology (GO) terms, find the nearest gene, exon, miRNA or
+custom features such as most conserved elements and other transcription factor
+binding sites supplied by users. Starting 2.0.5, new functions have been added
+for finding the peaks with bi-directional promoters with summary statistics
+(peaksNearBDP), for summarizing the occurrence of motifs in peaks
+(summarizePatternInPeaks) and for adding other IDs to annotated peaks or
+enrichedGO (addGeneIDs).")
+ (license license:gpl2+)))
+
+(define-public r-marray
+ (package
+ (name "r-marray")
+ (version "1.56.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "marray" version))
+ (sha256
+ (base32 "14c93i86yc7jn4ax8p4l0z6v9xisw1bv7gzb4a0gbxhxn7mddaic"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-limma" ,r-limma)))
+ (home-page "http://bioconductor.org/packages/marray")
+ (synopsis "Exploratory analysis for two-color spotted microarray data")
+ (description "This package contains class definitions for two-color spotted
+microarray data. It also includes fuctions for data input, diagnostic plots,
+normalization and quality checking.")
+ (license license:lgpl2.0+)))
+
+(define-public r-cghbase
+ (package
+ (name "r-cghbase")
+ (version "1.38.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "CGHbase" version))
+ (sha256
+ (base32 "0fynvcsjdbgp69i0nxrc8ni58rhb1kx9k5r3nb91n9i8s43gjqlm"))))
+ (properties `((upstream-name . "CGHbase")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-marray" ,r-marray)))
+ (home-page "http://bioconductor.org/packages/CGHbase")
+ (synopsis "Base functions and classes for arrayCGH data analysis")
+ (description "This package contains functions and classes that are needed by
+the @code{arrayCGH} packages.")
+ (license license:gpl2+)))
+
+(define-public r-cghcall
+ (package
+ (name "r-cghcall")
+ (version "2.40.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "CGHcall" version))
+ (sha256
+ (base32 "11pi6awz3858yb4s0z3qf3kcmsdgp6d4aj41g4lfix1sv5amllch"))))
+ (properties `((upstream-name . "CGHcall")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-cghbase" ,r-cghbase)
+ ("r-impute" ,r-impute)
+ ("r-dnacopy" ,r-dnacopy)
+ ("r-snowfall" ,r-snowfall)))
+ (home-page "http://bioconductor.org/packages/CGHcall")
+ (synopsis "Base functions and classes for arrayCGH data analysis")
+ (description "This package contains functions and classes that are needed by
+@code{arrayCGH} packages.")
+ (license license:gpl2+)))
+
+(define-public r-qdnaseq
+ (package
+ (name "r-qdnaseq")
+ (version "1.14.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "QDNAseq" version))
+ (sha256
+ (base32 "0lgbv4s0xqgrs7q6ynb3c273sf7pyrp51jnc8ravq1z5g0a2zshy"))))
+ (properties `((upstream-name . "QDNAseq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-cghbase" ,r-cghbase)
+ ("r-cghcall" ,r-cghcall)
+ ("r-dnacopy" ,r-dnacopy)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-iranges" ,r-iranges)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-r-utils" ,r-r-utils)
+ ("r-rsamtools" ,r-rsamtools)))
+ (home-page "http://bioconductor.org/packages/QDNAseq")
+ (synopsis "Quantitative DNA sequencing for chromosomal aberrations")
+ (description "The genome is divided into non-overlapping fixed-sized bins,
+number of sequence reads in each counted, adjusted with a simultaneous
+two-dimensional loess correction for sequence mappability and GC content, and
+filtered to remove spurious regions in the genome. Downstream steps of
+segmentation and calling are also implemented via packages DNAcopy and CGHcall,
+respectively.")
+ (license license:gpl2+)))