summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm785
1 files changed, 739 insertions, 46 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 89b191585b..0bcd9a67cd 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1,11 +1,15 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018, 2020 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016 Pjotr Prins <pjotr.guix@thebird.nl>
+;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019, 2020 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2019, 2020, 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 Peter Lo <peterloleungyau@gmail.com>
;;; Copyright © 2020, 2021 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -389,6 +393,25 @@ musculus (Mouse) as provided by UCSC (mm10, December 2011) and stored
in Biostrings objects.")
(license license:artistic2.0)))
+(define-public r-genomeinfodbdata
+ (package
+ (name "r-genomeinfodbdata")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "GenomeInfoDbData" version 'annotation))
+ (sha256
+ (base32
+ "0di6nlqpsyqf693k2na65ayqldih563x3zfrczpqc5q2hl5kg35c"))))
+ (properties
+ `((upstream-name . "GenomeInfoDbData")))
+ (build-system r-build-system)
+ (home-page "https://bioconductor.org/packages/GenomeInfoDbData")
+ (synopsis "Species and taxonomy ID look up tables for GenomeInfoDb")
+ (description "This package contains data for mapping between NCBI taxonomy
+ID and species. It is used by functions in the GenomeInfoDb package.")
+ (license license:artistic2.0)))
+
(define-public r-homo-sapiens
(package
(name "r-homo-sapiens")
@@ -905,6 +928,26 @@ All datasets are restricted to protein coding genes.")
from Illumina 450k methylation arrays.")
(license license:artistic2.0)))
+(define-public r-chromstardata
+ (package
+ (name "r-chromstardata")
+ (version "1.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "chromstaRData" version 'experiment))
+ (sha256
+ (base32
+ "0ph80d53598635bb8g61acg5rqwnj8644a0gh297r4hgbvwlflab"))))
+ (properties `((upstream-name . "chromstaRData")))
+ (build-system r-build-system)
+ (home-page "https://bioconductor.org/packages/chromstaRData/")
+ (synopsis "ChIP-seq data for demonstration purposes")
+ (description
+ "This package provides ChIP-seq data for demonstration purposes in the
+chromstaR package.")
+ (license license:gpl3)))
+
(define-public r-genelendatabase
(package
(name "r-genelendatabase")
@@ -1243,6 +1286,35 @@ and evaluate clustering results.")
arbitrary genomic intervals along chromosomal ideogram.")
(license license:gpl2)))
+(define-public r-iranges
+ (package
+ (name "r-iranges")
+ (version "2.24.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "IRanges" version))
+ (sha256
+ (base32
+ "01mx46a82vd3gz705pj0kk4wpxg683s8jqxchzjia3gz00b4qw52"))))
+ (properties
+ `((upstream-name . "IRanges")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-s4vectors" ,r-s4vectors)))
+ (home-page "https://bioconductor.org/packages/IRanges")
+ (synopsis "Infrastructure for manipulating intervals on sequences")
+ (description
+ "This package provides efficient low-level and highly reusable S4 classes
+for storing ranges of integers, RLE vectors (Run-Length Encoding), and, more
+generally, data that can be organized sequentially (formally defined as
+@code{Vector} objects), as well as views on these @code{Vector} objects.
+Efficient list-like classes are also provided for storing big collections of
+instances of the basic classes. All classes in the package use consistent
+naming and share the same rich and consistent \"Vector API\" as much as
+possible.")
+ (license license:artistic2.0)))
+
;; This is a CRAN package, but it depends on r-bsgenome-hsapiens-ucsc-hg19
;; from Bioconductor.
(define-public r-deconstructsigs
@@ -1487,6 +1559,298 @@ structure.")
microarrays.")
(license license:artistic2.0)))
+(define-public r-annotationforge
+ (package
+ (name "r-annotationforge")
+ (version "1.32.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AnnotationForge" version))
+ (sha256
+ (base32
+ "0y3820dkvwz09wlmz9drx6gqpsr9cwppaiz40zafwfxbz65y8px7"))))
+ (properties
+ `((upstream-name . "AnnotationForge")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-dbi" ,r-dbi)
+ ("r-rcurl" ,r-rcurl)
+ ("r-rsqlite" ,r-rsqlite)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-xml" ,r-xml)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/AnnotationForge")
+ (synopsis "Code for building annotation database packages")
+ (description
+ "This package provides code for generating Annotation packages and their
+databases. Packages produced are intended to be used with AnnotationDbi.")
+ (license license:artistic2.0)))
+
+(define-public r-category
+ (package
+ (name "r-category")
+ (version "2.56.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Category" version))
+ (sha256
+ (base32
+ "0m77wpnica0h2ia9ajdaiga4plgz1s9wls6pdnxzk7kwl8a68wkr"))))
+ (properties `((upstream-name . "Category")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotate" ,r-annotate)
+ ("r-annotationdbi" ,r-annotationdbi)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-genefilter" ,r-genefilter)
+ ("r-graph" ,r-graph)
+ ("r-gseabase" ,r-gseabase)
+ ("r-matrix" ,r-matrix)
+ ("r-rbgl" ,r-rbgl)
+ ("r-dbi" ,r-dbi)))
+ (home-page "https://bioconductor.org/packages/Category")
+ (synopsis "Category analysis")
+ (description
+ "This package provides a collection of tools for performing category
+analysis.")
+ (license license:artistic2.0)))
+
+(define-public r-deseq2
+ (package
+ (name "r-deseq2")
+ (version "1.30.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DESeq2" version))
+ (sha256
+ (base32
+ "1i0jpzsm1vl7q6qdmplj45w13lsaycxrx5pazlanjba2khn79k19"))))
+ (properties `((upstream-name . "DESeq2")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-biocparallel" ,r-biocparallel)
+ ("r-genefilter" ,r-genefilter)
+ ("r-geneplotter" ,r-geneplotter)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-iranges" ,r-iranges)
+ ("r-locfit" ,r-locfit)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/DESeq2")
+ (synopsis "Differential gene expression analysis")
+ (description
+ "This package provides functions to estimate variance-mean dependence in
+count data from high-throughput nucleotide sequencing assays and test for
+differential expression based on a model using the negative binomial
+distribution.")
+ (license license:lgpl3+)))
+
+(define-public r-dexseq
+ (package
+ (name "r-dexseq")
+ (version "1.36.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DEXSeq" version))
+ (sha256
+ (base32
+ "0wfjb42xcr4wjy8a654b74411dky8hp6sp8xdwf0sxqgsxy106qi"))))
+ (properties `((upstream-name . "DEXSeq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-biocparallel" ,r-biocparallel)
+ ("r-biomart" ,r-biomart)
+ ("r-deseq2" ,r-deseq2)
+ ("r-genefilter" ,r-genefilter)
+ ("r-geneplotter" ,r-geneplotter)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-hwriter" ,r-hwriter)
+ ("r-iranges" ,r-iranges)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-statmod" ,r-statmod)
+ ("r-stringr" ,r-stringr)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/DEXSeq")
+ (synopsis "Inference of differential exon usage in RNA-Seq")
+ (description
+ "This package is focused on finding differential exon usage using RNA-seq
+exon counts between samples with different experimental designs. It provides
+functions that allows the user to make the necessary statistical tests based
+on a model that uses the negative binomial distribution to estimate the
+variance between biological replicates and generalized linear models for
+testing. The package also provides functions for the visualization and
+exploration of the results.")
+ (license license:gpl3+)))
+
+(define-public r-edger
+ (package
+ (name "r-edger")
+ (version "3.32.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "edgeR" version))
+ (sha256
+ (base32
+ "1gaic8qf6a6sy0bmydh1xzf52w0wnq31aanpvw3a30pfsi218bcp"))))
+ (properties `((upstream-name . "edgeR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-limma" ,r-limma)
+ ("r-locfit" ,r-locfit)
+ ("r-rcpp" ,r-rcpp)
+ ("r-statmod" ,r-statmod))) ;for estimateDisp
+ (home-page "http://bioinf.wehi.edu.au/edgeR")
+ (synopsis "EdgeR does empirical analysis of digital gene expression data")
+ (description "This package can do differential expression analysis of
+RNA-seq expression profiles with biological replication. It implements a range
+of statistical methodology based on the negative binomial distributions,
+including empirical Bayes estimation, exact tests, generalized linear models
+and quasi-likelihood tests. It be applied to differential signal analysis of
+other types of genomic data that produce counts, including ChIP-seq, SAGE and
+CAGE.")
+ (license license:gpl2+)))
+
+(define-public r-genefilter
+ (package
+ (name "r-genefilter")
+ (version "1.72.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "genefilter" version))
+ (sha256
+ (base32
+ "1c6h3qnjvphs977qhv5vafvsb108r0q7xhaayly6qv6adqfn94rn"))))
+ (build-system r-build-system)
+ (native-inputs
+ `(("gfortran" ,gfortran)
+ ("r-knitr" ,r-knitr)))
+ (propagated-inputs
+ `(("r-annotate" ,r-annotate)
+ ("r-annotationdbi" ,r-annotationdbi)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-survival" ,r-survival)))
+ (home-page "https://bioconductor.org/packages/genefilter")
+ (synopsis "Filter genes from high-throughput experiments")
+ (description
+ "This package provides basic functions for filtering genes from
+high-throughput sequencing experiments.")
+ (license license:artistic2.0)))
+
+(define-public r-genomeinfodb
+ (package
+ (name "r-genomeinfodb")
+ (version "1.26.4")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "GenomeInfoDb" version))
+ (sha256
+ (base32
+ "1sbhdpgabqbi749ixih8nlmq5id7sg8y6kkfj46r00642rc293ys"))))
+ (properties
+ `((upstream-name . "GenomeInfoDb")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-genomeinfodbdata" ,r-genomeinfodbdata)
+ ("r-iranges" ,r-iranges)
+ ("r-rcurl" ,r-rcurl)
+ ("r-s4vectors" ,r-s4vectors)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/GenomeInfoDb")
+ (synopsis "Utilities for manipulating chromosome identifiers")
+ (description
+ "This package contains data and functions that define and allow
+translation between different chromosome sequence naming conventions (e.g.,
+\"chr1\" versus \"1\"), including a function that attempts to place sequence
+names in their natural, rather than lexicographic, order.")
+ (license license:artistic2.0)))
+
+(define-public r-gostats
+ (package
+ (name "r-gostats")
+ (version "2.56.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "GOstats" version))
+ (sha256
+ (base32
+ "18q8p0fv9fl2r6zjxknfjwqxr69dlyxy6c8amzn6c6dwjq1cxk6j"))))
+ (properties `((upstream-name . "GOstats")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotate" ,r-annotate)
+ ("r-annotationdbi" ,r-annotationdbi)
+ ("r-annotationforge" ,r-annotationforge)
+ ("r-biobase" ,r-biobase)
+ ("r-category" ,r-category)
+ ("r-go-db" ,r-go-db)
+ ("r-graph" ,r-graph)
+ ("r-rgraphviz" ,r-rgraphviz)
+ ("r-rbgl" ,r-rbgl)))
+ (home-page "https://bioconductor.org/packages/GOstats")
+ (synopsis "Tools for manipulating GO and microarrays")
+ (description
+ "This package provides a set of tools for interacting with GO and
+microarray data. A variety of basic manipulation tools for graphs, hypothesis
+testing and other simple calculations.")
+ (license license:artistic2.0)))
+
+(define-public r-gseabase
+ (package
+ (name "r-gseabase")
+ (version "1.52.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "GSEABase" version))
+ (sha256
+ (base32
+ "0dawh1kjmf6921jm77j2s2phrq5237pjc4sdh8fkln89gf48zx6i"))))
+ (properties `((upstream-name . "GSEABase")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotate" ,r-annotate)
+ ("r-annotationdbi" ,r-annotationdbi)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-graph" ,r-graph)
+ ("r-xml" ,r-xml)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/GSEABase")
+ (synopsis "Gene set enrichment data structures and methods")
+ (description
+ "This package provides classes and methods to support @dfn{Gene Set
+Enrichment Analysis} (GSEA).")
+ (license license:artistic2.0)))
+
(define-public r-hpar
(package
(name "r-hpar")
@@ -1507,6 +1871,29 @@ microarrays.")
the Human Protein Atlas project.")
(license license:artistic2.0)))
+(define-public r-rbgl
+ (package
+ (name "r-rbgl")
+ (version "1.66.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "RBGL" version))
+ (sha256
+ (base32
+ "016vyzgixb3gjpzi21rbs6ngnnqcxr77krwjjf1ldnzzj8vqrqsz"))))
+ (properties `((upstream-name . "RBGL")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bh" ,r-bh)
+ ("r-graph" ,r-graph)))
+ (home-page "https://www.bioconductor.org/packages/RBGL")
+ (synopsis "Interface to the Boost graph library")
+ (description
+ "This package provides a fairly extensive and comprehensive interface to
+the graph algorithms contained in the Boost library.")
+ (license license:artistic2.0)))
+
(define-public r-regioner
(package
(name "r-regioner")
@@ -1541,14 +1928,14 @@ region sets and other genomic features.")
(define-public r-reportingtools
(package
(name "r-reportingtools")
- (version "2.30.0")
+ (version "2.30.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "ReportingTools" version))
(sha256
(base32
- "0gkshdhx44yjffqf1xmvik7j5hlhszp1n9ckanaws9ky3iia8j31"))))
+ "1vvra7l29s7lnq996nwlpzbkrbdkr3ivkgmfp4kndfykxsl9q4vb"))))
(properties
`((upstream-name . "ReportingTools")))
(build-system r-build-system)
@@ -1588,6 +1975,141 @@ reports together for a particular project that can be viewed in a web
browser.")
(license license:artistic2.0)))
+(define-public r-shortread
+ (package
+ (name "r-shortread")
+ (version "1.48.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ShortRead" version))
+ (sha256
+ (base32
+ "0w4m8d3h660mmr2ymp206r1n4aqssxmkv8yxkbr5y1swrahxzfk9"))))
+ (properties `((upstream-name . "ShortRead")))
+ (build-system r-build-system)
+ (inputs
+ `(("zlib" ,zlib)))
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-biocparallel" ,r-biocparallel)
+ ("r-biostrings" ,r-biostrings)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-rhtslib" ,r-rhtslib)
+ ("r-hwriter" ,r-hwriter)
+ ("r-iranges" ,r-iranges)
+ ("r-lattice" ,r-lattice)
+ ("r-latticeextra" ,r-latticeextra)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-xvector" ,r-xvector)
+ ("r-zlibbioc" ,r-zlibbioc)))
+ (home-page "https://bioconductor.org/packages/ShortRead")
+ (synopsis "FASTQ input and manipulation tools")
+ (description
+ "This package implements sampling, iteration, and input of FASTQ files.
+It includes functions for filtering and trimming reads, and for generating a
+quality assessment report. Data are represented as
+@code{DNAStringSet}-derived objects, and easily manipulated for a diversity of
+purposes. The package also contains legacy support for early single-end,
+ungapped alignment formats.")
+ (license license:artistic2.0)))
+
+(define-public r-systempiper
+ (package
+ (name "r-systempiper")
+ (version "1.24.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "systemPipeR" version))
+ (sha256
+ (base32
+ "0ffazyl2q9plbhwlxi04s3fvnli6qj95n7bkjc21535bbi08xfki"))))
+ (properties `((upstream-name . "systemPipeR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotate" ,r-annotate)
+ ("r-assertthat" ,r-assertthat)
+ ("r-batchtools" ,r-batchtools)
+ ("r-biostrings" ,r-biostrings)
+ ("r-deseq2" ,r-deseq2)
+ ("r-dot" ,r-dot)
+ ("r-edger" ,r-edger)
+ ("r-genomicfeatures" ,r-genomicfeatures)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-go-db" ,r-go-db)
+ ("r-gostats" ,r-gostats)
+ ("r-iranges" ,r-iranges)
+ ("r-limma" ,r-limma)
+ ("r-magrittr" ,r-magrittr)
+ ("r-pheatmap" ,r-pheatmap)
+ ("r-rjson" ,r-rjson)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-rsvg" ,r-rsvg)
+ ("r-shortread" ,r-shortread)
+ ("r-stringr" ,r-stringr)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)
+ ("r-yaml" ,r-yaml)
+ ("r-variantannotation" ,r-variantannotation)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/tgirke/systemPipeR")
+ (synopsis "Next generation sequencing workflow and reporting environment")
+ (description
+ "This R package provides tools for building and running automated
+end-to-end analysis workflows for a wide range of @dfn{next generation
+sequence} (NGS) applications such as RNA-Seq, ChIP-Seq, VAR-Seq and Ribo-Seq.
+Important features include a uniform workflow interface across different NGS
+applications, automated report generation, and support for running both R and
+command-line software, such as NGS aligners or peak/variant callers, on local
+computers or compute clusters. Efficient handling of complex sample sets and
+experimental designs is facilitated by a consistently implemented sample
+annotation infrastructure.")
+ (license license:artistic2.0)))
+
+(define-public r-variantannotation
+ (package
+ (name "r-variantannotation")
+ (version "1.36.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "VariantAnnotation" version))
+ (sha256
+ (base32
+ "1sl0l6v05lfglj281nszma0h5k234md7rn2pdah8vs2d4iq3kimw"))))
+ (properties
+ `((upstream-name . "VariantAnnotation")))
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-biostrings" ,r-biostrings)
+ ("r-bsgenome" ,r-bsgenome)
+ ("r-dbi" ,r-dbi)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicfeatures" ,r-genomicfeatures)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-iranges" ,r-iranges)
+ ("r-matrixgenerics" ,r-matrixgenerics)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)
+ ("r-rhtslib" ,r-rhtslib)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-xvector" ,r-xvector)
+ ("r-zlibbioc" ,r-zlibbioc)))
+ (build-system r-build-system)
+ (home-page "https://bioconductor.org/packages/VariantAnnotation")
+ (synopsis "Package for annotation of genetic variants")
+ (description "This R package can annotate variants, compute amino acid
+coding changes and predict coding outcomes.")
+ (license license:artistic2.0)))
+
(define-public r-geneplotter
(package
(name "r-geneplotter")
@@ -1796,14 +2318,14 @@ signal in the input, that lead to spurious peaks during peak calling.")
(define-public r-diffbind
(package
(name "r-diffbind")
- (version "3.0.13")
+ (version "3.0.14")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "DiffBind" version))
(sha256
(base32
- "0kxn59v93hl5pq8d156lnbz0sslpnxyjcfrvq2gzgd91sd587qmn"))))
+ "1siabhjd0w7bb6v2gfhsm9j7c7c86z8m6lfsyl8p84h0zhjs2vrw"))))
(properties `((upstream-name . "DiffBind")))
(build-system r-build-system)
(propagated-inputs
@@ -3688,33 +4210,6 @@ visualising metrics relative to experiment run time or spatially over the
surface of a flowcell.")
(license license:expat)))
-;; This is a CRAN package, but it depends on packages from Bioconductor.
-(define-public r-gkmsvm
- (package
- (name "r-gkmsvm")
- (version "0.81.0")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "gkmSVM" version))
- (sha256
- (base32
- "119g5rhc7ffyviz04r04aj5z1g6abnj3ddd01g7db505sdr6lapj"))))
- (properties `((upstream-name . "gkmSVM")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-kernlab" ,r-kernlab)
- ("r-rcpp" ,r-rcpp)
- ("r-rocr" ,r-rocr)
- ("r-seqinr" ,r-seqinr)))
- (home-page "https://cran.r-project.org/web/packages/gkmSVM")
- (synopsis "Gapped-kmer support vector machine")
- (description
- "This R package provides tools for training gapped-kmer SVM classifiers
-for DNA and protein sequences. This package supports several sequence
-kernels, including: gkmSVM, kmer-SVM, mismatch kernel and wildcard kernel.")
- (license license:gpl2+)))
-
;; This is a CRAN package, but it depends on multtest from Bioconductor.
(define-public r-mutoss
(package
@@ -6525,14 +7020,14 @@ sequential way to mimic the manual gating strategy.")
(define-public r-cytoml
(package
(name "r-cytoml")
- (version "2.2.1")
+ (version "2.2.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "CytoML" version))
(sha256
(base32
- "1d8x49aqc95x1vx456hya5r7mal80pj9l6wmr5x5pb5r8qyzz6yq"))))
+ "0ckjb7bkz0cy46scrv4vl9w37g54c0yihvzmbkzilip1ikpvhxd1"))))
(properties `((upstream-name . "CytoML")))
(build-system r-build-system)
(arguments
@@ -6547,7 +7042,8 @@ sequential way to mimic the manual gating strategy.")
(string-append match "/libhdf5.a")))
#t)))))
(inputs
- `(("libxml2" ,libxml2)))
+ `(("libxml2" ,libxml2)
+ ("zlib" ,zlib)))
(propagated-inputs
`(("r-base64enc" ,r-base64enc)
("r-bh" ,r-bh)
@@ -6813,14 +7309,14 @@ accessibility data.")
(define-public r-circrnaprofiler
(package
(name "r-circrnaprofiler")
- (version "1.4.0")
+ (version "1.4.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "circRNAprofiler" version))
(sha256
(base32
- "1rwpl9a5p5242aiapik0vf4ywqh7m6phzl8z8qmzcy0imbx7mpbn"))))
+ "0r1hfm3pc7c71irzmxmdwc27ns9hkymz4vhb4pqbli4xn37q7cg8"))))
(properties
`((upstream-name . "circRNAprofiler")))
(build-system r-build-system)
@@ -7915,14 +8411,14 @@ visualizing RNA-sequencing datasets and differentially expressed genes.")
(define-public r-chemminer
(package
(name "r-chemminer")
- (version "3.42.1")
+ (version "3.42.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "ChemmineR" version))
(sha256
(base32
- "1853w19042c53whdnrfg1v8f07wpswf2si8q4613yrcamzg2zjkx"))))
+ "10d8h6w24h4s7l02zzv6q46w3yiqsjizip7mf11cvkmd6p7qxfl9"))))
(properties `((upstream-name . "ChemmineR")))
(build-system r-build-system)
(propagated-inputs
@@ -7956,14 +8452,14 @@ structures.")
(define-public r-bioassayr
(package
(name "r-bioassayr")
- (version "1.28.0")
+ (version "1.28.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "bioassayR" version))
(sha256
(base32
- "0vxnd8wnhjdfqh47nc6y1ffiy5r9a6n3g2hyk1r9bv6vhrd0ns3f"))))
+ "0ylnnm31jkmi8zz78kngqv36yn6i5lvjp1i27v59svw13m4r03g5"))))
(properties `((upstream-name . "bioassayR")))
(build-system r-build-system)
(propagated-inputs
@@ -7976,7 +8472,7 @@ structures.")
("r-xml" ,r-xml)))
(native-inputs
`(("r-knitr" ,r-knitr)))
- (home-page "https://github.com/TylerBackman/bioassayR")
+ (home-page "https://github.com/girke-lab/bioassayR")
(synopsis "Cross-target analysis of small molecule bioactivity")
(description
"bioassayR is a computational tool that enables simultaneous analysis of
@@ -8125,6 +8621,55 @@ microarray data.")
monograph.")
(license license:artistic2.0)))
+(define-public r-bioccheck
+ (package
+ (name "r-bioccheck")
+ (version "1.26.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BiocCheck" version))
+ (sha256
+ (base32
+ "1hyncn9zqj432da95k86rm5b28nbwrvzm52jbhisifkxj1j43cib"))))
+ (properties
+ `((upstream-name . "BiocCheck")))
+ (build-system r-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; This package can be used by calling BiocCheck(<package>) from
+ ;; within R, or by running R CMD BiocCheck <package>. This phase
+ ;; makes sure the latter works. For this to work, the BiocCheck
+ ;; script must be somewhere on the PATH (not the R bin directory).
+ (add-after 'install 'install-bioccheck-subcommand
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (dest-dir (string-append out "/bin"))
+ (script-dir
+ (string-append out "/site-library/BiocCheck/script/")))
+ (mkdir-p dest-dir)
+ (symlink (string-append script-dir "/checkBadDeps.R")
+ (string-append dest-dir "/checkBadDeps.R"))
+ (symlink (string-append script-dir "/BiocCheck")
+ (string-append dest-dir "/BiocCheck")))
+ #t)))))
+ (propagated-inputs
+ `(("r-codetools" ,r-codetools)
+ ("r-graph" ,r-graph)
+ ("r-httr" ,r-httr)
+ ("r-knitr" ,r-knitr)
+ ("r-optparse" ,r-optparse)
+ ("r-biocmanager" ,r-biocmanager)
+ ("r-biocviews" ,r-biocviews)
+ ("r-stringdist" ,r-stringdist)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/BiocCheck")
+ (synopsis "Executes Bioconductor-specific package checks")
+ (description "This package contains tools to perform additional quality
+checks on R packages that are to be submitted to the Bioconductor repository.")
+ (license license:artistic2.0)))
+
(define-public r-biocgraph
(package
(name "r-biocgraph")
@@ -8150,6 +8695,62 @@ monograph.")
different graph related packages produced by Bioconductor.")
(license license:artistic2.0)))
+(define-public r-biocstyle
+ (package
+ (name "r-biocstyle")
+ (version "2.18.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BiocStyle" version))
+ (sha256
+ (base32
+ "0rsxyna4dd99x42vc82mlkxx774vb9375llpakg53max1hhwkrqp"))))
+ (properties
+ `((upstream-name . "BiocStyle")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocmanager" ,r-biocmanager)
+ ("r-bookdown" ,r-bookdown)
+ ("r-knitr" ,r-knitr)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-yaml" ,r-yaml)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/BiocStyle")
+ (synopsis "Bioconductor formatting styles")
+ (description "This package provides standard formatting styles for
+Bioconductor PDF and HTML documents. Package vignettes illustrate use and
+functionality.")
+ (license license:artistic2.0)))
+
+(define-public r-biocviews
+ (package
+ (name "r-biocviews")
+ (version "1.58.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "biocViews" version))
+ (sha256
+ (base32
+ "1by2639z7n62z84dr8rj9jz12gsd1k8q42zsnxacxbwfwp6h0cl4"))))
+ (properties
+ `((upstream-name . "biocViews")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-biocmanager" ,r-biocmanager)
+ ("r-graph" ,r-graph)
+ ("r-rbgl" ,r-rbgl)
+ ("r-rcurl" ,r-rcurl)
+ ("r-xml" ,r-xml)
+ ("r-runit" ,r-runit)))
+ (home-page "https://bioconductor.org/packages/biocViews")
+ (synopsis "Bioconductor package categorization helper")
+ (description "The purpose of biocViews is to create HTML pages that
+categorize packages in a Bioconductor package repository according to keywords,
+also known as views, in a controlled vocabulary.")
+ (license license:artistic2.0)))
+
(define-public r-experimenthub
(package
(name "r-experimenthub")
@@ -8184,6 +8785,33 @@ and manages a local cache of files retrieved enabling quick and reproducible
access.")
(license license:artistic2.0)))
+(define-public r-grohmm
+ (package
+ (name "r-grohmm")
+ (version "1.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "groHMM" version))
+ (sha256
+ (base32
+ "08pap9wsaxl4jjlc1py0rc019gmi6daa0f9cr3ih1d97wybncanx"))))
+ (properties `((upstream-name . "groHMM")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-iranges" ,r-iranges)
+ ("r-mass" ,r-mass)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-s4vectors" ,r-s4vectors)))
+ (home-page "https://github.com/Kraus-Lab/groHMM")
+ (synopsis "GRO-seq analysis pipeline")
+ (description
+ "This package provides a pipeline for the analysis of GRO-seq data.")
+ (license license:gpl3+)))
+
(define-public r-multiassayexperiment
(package
(name "r-multiassayexperiment")
@@ -8695,19 +9323,46 @@ generated.")
routines.")
(license license:lgpl2.0+)))
+(define-public r-s4vectors
+ (package
+ (name "r-s4vectors")
+ (version "0.28.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "S4Vectors" version))
+ (sha256
+ (base32
+ "0fhf4lsfxrim7glazh6ng46ykzaly5ggwpg170vcz4cc24prv0rh"))))
+ (properties
+ `((upstream-name . "S4Vectors")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)))
+ (home-page "https://bioconductor.org/packages/S4Vectors")
+ (synopsis "S4 implementation of vectors and lists")
+ (description
+ "The S4Vectors package defines the @code{Vector} and @code{List} virtual
+classes and a set of generic functions that extend the semantic of ordinary
+vectors and lists in R. Package developers can easily implement vector-like
+or list-like objects as concrete subclasses of @code{Vector} or @code{List}.
+In addition, a few low-level concrete subclasses of general interest (e.g.
+@code{DataFrame}, @code{Rle}, and @code{Hits}) are implemented in the
+S4Vectors package itself.")
+ (license license:artistic2.0)))
+
;; This is a CRAN package, but it depends on preprocessorcore, which is a
;; Bioconductor package.
(define-public r-wgcna
(package
(name "r-wgcna")
- (version "1.69")
+ (version "1.70-3")
(source
(origin
(method url-fetch)
(uri (cran-uri "WGCNA" version))
(sha256
(base32
- "022hkprnrafvggi8pkjffkvk1qlnibmbbxxrni00wkrdbga5589f"))))
+ "1m6b4a2xpb02c1ajndhk8qlqnhwxa7lkkwj6nzv3l618jy1kp15r"))))
(properties `((upstream-name . "WGCNA")))
(build-system r-build-system)
(propagated-inputs
@@ -9223,13 +9878,13 @@ of other packages.")
(define-public r-scater
(package
(name "r-scater")
- (version "1.18.3")
+ (version "1.18.6")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "scater" version))
(sha256
(base32
- "14f7yw277nykxmcm7wlhlsf3nizpwzz24hax1icx73lavfxmc535"))))
+ "0k1ls5gqv1zsn1w2kszhmbhwfccfjw8khk36s5zbf90rbbkw5609"))))
(build-system r-build-system)
(propagated-inputs
`(("r-biocgenerics" ,r-biocgenerics)
@@ -9988,6 +10643,44 @@ large-scale and fully automated analysis.")
the earlier snpMatrix package, allowing for uncertainty in genotypes.")
(license license:gpl3)))
+(define-public r-chromstar
+ (package
+ (name "r-chromstar")
+ (version "1.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "chromstaR" version))
+ (sha256
+ (base32
+ "0vgpb7g2cncdn82hia2yzzachyns2zbd7906662g990qjnp2xlm1"))))
+ (properties `((upstream-name . "chromstaR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bamsignals" ,r-bamsignals)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-chromstardata" ,r-chromstardata)
+ ("r-doparallel" ,r-doparallel)
+ ("r-foreach" ,r-foreach)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-iranges" ,r-iranges)
+ ("r-mvtnorm" ,r-mvtnorm)
+ ("r-reshape2" ,r-reshape2)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-s4vectors" ,r-s4vectors)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/ataudt/chromstaR")
+ (synopsis "Chromatin state analysis for ChIP-Seq data")
+ (description
+ "This package implements functions for combinatorial and differential
+analysis of ChIP-seq data. It includes uni- and multivariate peak-calling,
+export to genome browser viewable files, and functi ons for enrichment
+analyses.")
+ (license license:artistic2.0)))
+
(define-public r-sushi
(package
(name "r-sushi")