summaryrefslogtreecommitdiff
path: root/gnu/packages/benchmark.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/benchmark.scm')
-rw-r--r--gnu/packages/benchmark.scm25
1 files changed, 17 insertions, 8 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index f9648b5f7c..fa70d2773e 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 malte Frank Gerdes <malte.f.gerdes@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -46,14 +47,14 @@
(define-public fio
(package
(name "fio")
- (version "3.23")
+ (version "3.24")
(source (origin
(method url-fetch)
(uri (string-append "https://brick.kernel.dk/snaps/"
"fio-" version ".tar.bz2"))
(sha256
(base32
- "0cy32431hv0i84yrryna5byj4r610n6i1rm8nfflnrznbf051axs"))))
+ "0qshbyqpvm01hmpkmk0v0jhjz23sngqhy291kiz38z04s2df4vxn"))))
(build-system gnu-build-system)
(arguments
'(#:test-target "test"
@@ -213,7 +214,7 @@ This can give a much better understanding of the command's performance.")
(define-public benchmark
(package
(name "benchmark")
- (version "1.5.0")
+ (version "1.5.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -222,16 +223,24 @@ This can give a much better understanding of the command's performance.")
(file-name (git-file-name name version))
(sha256
(base32
- "0r9dbg4cbk47gwmayys31a83m3y67k0kh1f6pl8i869rbd609ndh"))
- (patches (search-patches "benchmark-unbundle-googletest.patch"))))
+ "13rxagpzw6bal6ajlmrxlh9kgfvcixn6j734b2bvfqz7lch8n0pa"))))
(build-system cmake-build-system)
(native-inputs
- `(("googletest" ,googletest)))
+ `(("googletest-source" ,(package-source googletest))
+ ("googletest" ,googletest)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-googletest
+ (lambda* (#:key inputs #:allow-other-keys)
+ (copy-recursively (assoc-ref inputs "googletest-source")
+ "googletest")
+ #t)))))
(home-page "https://github.com/google/benchmark")
(synopsis "Microbenchmark support library")
(description
- "Benchmark is a library to benchmark code snippets,
-similar to unit tests.")
+ "Benchmark is a library to benchmark code snippets, similar to unit
+tests.")
(license license:asl2.0)))
(define-public bonnie++