summaryrefslogtreecommitdiff
path: root/gnu/packages/benchmark.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/benchmark.scm')
-rw-r--r--gnu/packages/benchmark.scm36
1 files changed, 32 insertions, 4 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 577196e3df..d9796d2999 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -41,6 +41,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
+ #:use-module (gnu packages opencl)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
#:use-module (gnu packages python-science)
@@ -220,7 +221,7 @@ This can give a much better understanding of the command's performance.")
(define-public benchmark
(package
(name "benchmark")
- (version "1.5.5")
+ (version "1.5.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -229,7 +230,7 @@ This can give a much better understanding of the command's performance.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ijv4idcjsyy61dab59ywbx0xdbws44kxgqjr1ylaxzwknh745qf"))))
+ "030g4d8vpn2442dsap0qw86lsw7xfl36k0x0x9bn0vvm11qvjn8c"))))
(build-system cmake-build-system)
(native-inputs
`(("googletest-source" ,(package-source googletest))
@@ -240,8 +241,7 @@ This can give a much better understanding of the command's performance.")
(add-after 'unpack 'unpack-googletest
(lambda* (#:key inputs #:allow-other-keys)
(copy-recursively (assoc-ref inputs "googletest-source")
- "googletest")
- #t)))))
+ "googletest"))))))
(home-page "https://github.com/google/benchmark")
(synopsis "Microbenchmark support library")
(description
@@ -384,3 +384,31 @@ It is designed to measure the effect of changes in Linux kernel design or
system configuration changes such as CPU, I/O scheduler and filesystem changes
and options. With careful benchmarking, different hardware can be compared.")
(license license:gpl2+)))
+
+(define-public clpeak
+ ;; Release 1.1.0 is too old for our opencl-clhpp. This commit supports
+ ;; cl2.hpp.
+ (let ((commit "6d59cb64997a53c35207b77a63d2e9f0e84de5fd"))
+ (package
+ (name "clpeak")
+ (version (git-version "1.1.0" "0" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/krrishnarraj/clpeak.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qmhdjyhwl7gfgyqxsddqn6zpp3b57503m16h7jv6illy3lfvji1"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/krrishnarraj/clpeak")
+ (inputs
+ `(("opencl-clhpp" ,opencl-clhpp)
+ ("opencl-icd-loader" ,opencl-icd-loader)))
+ (synopsis "OpenCL benchmark tool")
+ (description
+ "A synthetic benchmarking tool to measure peak capabilities of OpenCL
+ devices. It only measures the peak metrics that can be achieved using
+ vector operations and does not represent a real-world use case.")
+ (license license:unlicense))))