summaryrefslogtreecommitdiff
path: root/gnu/packages/bdb.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bdb.scm')
-rw-r--r--gnu/packages/bdb.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/bdb.scm b/gnu/packages/bdb.scm
index c9cdf4af6b..9a626b17d7 100644
--- a/gnu/packages/bdb.scm
+++ b/gnu/packages/bdb.scm
@@ -35,19 +35,18 @@
"1f2g2612lf8djbwbwhxsvmffmf9d7693kh2l20195pqp0f9jmnfx"))))
(build-system gnu-build-system)
(arguments
- (lambda (system)
- `(#:tests? #f ; no check target available
- #:phases
- (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (zero?
- (system* "./dist/configure"
- (string-append "--prefix=" out)
- (string-append "CONFIG_SHELL=" (which "bash"))
- (string-append "SHELL=" (which "bash"))))))
- %standard-phases))))
+ '(#:tests? #f ; no check target available
+ #:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (zero?
+ (system* "./dist/configure"
+ (string-append "--prefix=" out)
+ (string-append "CONFIG_SHELL=" (which "bash"))
+ (string-append "SHELL=" (which "bash"))))))
+ %standard-phases)))
(synopsis "db, the Berkeley database")
(description
"Berkeley DB is an embeddable database allowing developers the choice of