summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index c83775d8ee..47fca7c494 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -324,7 +324,7 @@ used to apply commands with arbitrarily long arguments.")
,@(if (and (not (%current-target-system))
(member (%current-system)
(package-supported-systems libcap)))
- `(("libcap" ,libcap)) ;capability support in 'ls', etc.
+ `(("libcap" ,libcap-2.31)) ;capability support in 'ls', etc.
'())))
(native-inputs
;; Perl is needed to run tests in native builds, and to run the bundled
@@ -1229,7 +1229,7 @@ command.")
(define-public tzdata
(package
(name "tzdata")
- (version "2020a")
+ (version "2020d")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1237,10 +1237,10 @@ command.")
version ".tar.gz"))
(sha256
(base32
- "18lrp0zh8m931jjlrv8lvjas4ka5dfkzdbwnbw5lwd2dlbn62wal"))))
+ "1wxskk9mh1x2073n99qna2mq58mgi648mbq5dxlqfcrnvrbkk0cd"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f
+ `(#:tests? #f
#:make-flags (let ((out (assoc-ref %outputs "out"))
(tmp (getenv "TMPDIR")))
(list (string-append "TOPDIR=" out)
@@ -1252,6 +1252,16 @@ command.")
(string-append "LIBDIR=" tmp "/lib")
(string-append "MANDIR=" tmp "/man")
+ ;; XXX: tzdata 2020b changed the on-disk format
+ ;; of the time zone files from 'fat' to 'slim'.
+ ;; Many packages (particularly evolution-data-server)
+ ;; can not yet handle the latter, so we stick with
+ ;; 'fat' for now.
+ ,@(if (version>=? (package-version this-package)
+ "2020b")
+ '("CPPFLAGS=-DZIC_BLOAT_DEFAULT='\"fat\"'")
+ '())
+
"AWK=awk"
"CC=gcc"))
#:modules ((guix build utils)
@@ -1287,7 +1297,7 @@ command.")
version ".tar.gz"))
(sha256
(base32
- "0sfnlqw1p93r7klny69rwr94fh22mz632h52phgzfgg01q9gfakx"))))))
+ "1mgsckixmmk9qxzsflfxnp3999qi3ls72bgksclk01g852x51w3c"))))))
(home-page "https://www.iana.org/time-zones")
(synopsis "Database of current and historical time zones")
(description "The Time Zone Database (often called tz or zoneinfo)