summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index aa5200294f..da18a9d60b 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -395,6 +395,31 @@ change. GNU make offers many powerful extensions over the standard utility.")
(license gpl3+)
(home-page "https://www.gnu.org/software/make/")))
+(define-public gnu-make-4.2
+ (package
+ (inherit gnu-make)
+ (version "4.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/make/make-" version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "12f5zzyq2w56g95nni65hc0g5p7154033y2f3qmjvd016szn5qnn"))))
+ (arguments
+ `(#:configure-flags '("CFLAGS=-D__alloca=alloca")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-default-shell
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Change the default shell from /bin/sh.
+ (let ((bash (assoc-ref inputs "bash")))
+ (substitute* "job.c"
+ (("default_shell =.*$")
+ (format #f "default_shell = \"~a/bin/sh\";\n"
+ bash)))
+ #t))))))))
+
(define-public binutils
(package
(name "binutils")