summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index c8fd8624af..8190a38ed4 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -523,11 +523,15 @@ store.")
;; archive can be generated by checking out the commit ID and running:
;; git archive --prefix=$(git describe)/ HEAD | xz -9 > $(git describe).tar.xz
;; See <https://bugs.gnu.org/29406> for details.
- (version "2.26-91-gaaa2eb83b8")
+ ;;
+ ;; Note: Always use a dot after the minor version since various places rely
+ ;; on "version-major+minor" to determine where locales are found.
+ (version "2.26.91-gaaa2eb83b8")
(source (origin
(method url-fetch)
(uri (string-append "https://alpha.gnu.org/gnu/guix/mirror/"
- "glibc-" version ".tar.xz"))
+ "glibc-" (version-major+minor version) "-"
+ (caddr (string-split version #\.)) ".tar.xz"))
(sha256
(base32
"1zwz6d0x3ndd0hgqp17fx71miyjvn4dgkl1nzhaz3mbcqxzrprhk"))
@@ -585,7 +589,7 @@ store.")
;; `--localedir' is not honored, so work around it.
;; See <http://sourceware.org/ml/libc-alpha/2013-03/msg00093.html>.
(string-append "libc_cv_complocaledir=/run/current-system/locale/"
- ,version)
+ ,(version-major+minor version))
(string-append "--with-headers="
(assoc-ref ,(if (%current-target-system)
@@ -955,7 +959,8 @@ the 'share/locale' sub-directory of this package.")
(list (string-append "libc_cv_complocaledir="
(assoc-ref %outputs "out")
"/lib/locale/"
- ,(package-version glibc))))))))))
+ ,(version-major+minor
+ (package-version glibc)))))))))))
(define-public glibc-utf8-locales
(package
@@ -973,7 +978,7 @@ the 'share/locale' sub-directory of this package.")
(gzip (assoc-ref %build-inputs "gzip"))
(out (assoc-ref %outputs "out"))
(localedir (string-append out "/lib/locale/"
- ,version)))
+ ,(version-major+minor version))))
;; 'localedef' needs 'gzip'.
(setenv "PATH" (string-append libc "/bin:" gzip "/bin"))