summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm87
1 files changed, 49 insertions, 38 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 74acd791ac..fb6d000170 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015, 2020 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -55,6 +55,7 @@
#:use-module (gnu packages dbm)
#:use-module (gnu packages dejagnu)
#:use-module (gnu packages ftp)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
@@ -80,7 +81,7 @@
(define-public duplicity
(package
(name "duplicity")
- (version "0.7.19")
+ (version "0.8.14")
(source
(origin
(method url-fetch)
@@ -89,32 +90,36 @@
"-series/" version "/+download/duplicity-"
version ".tar.gz"))
(sha256
- (base32 "0ag9dknslxlasslwfjhqgcqbkb1mvzzx93ry7lch2lfzcdd91am6"))))
+ (base32 "1af7rppsd8kj66xhbc04x1di3rpncrz0prxq1z7npg11c769vb1x"))))
(build-system python-build-system)
(native-inputs
- `(("util-linux" ,util-linux) ; setsid command, for the tests
+ `(("gettext" ,gnu-gettext) ; for msgfmt
+ ("util-linux" ,util-linux) ; setsid command, for the tests
("par2cmdline" ,par2cmdline)
- ("python-pexpect" ,python2-pexpect)
- ("python-fasteners" ,python2-fasteners)
+ ("python-fasteners" ,python-fasteners)
+ ("python-future" ,python-future) ; for tests
+ ("python-pexpect" ,python-pexpect)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-setuptools-scm" ,python-setuptools-scm)
("tzdata" ,tzdata-for-tests)
- ("mock" ,python2-mock)))
+ ("mock" ,python-mock)))
(propagated-inputs
- `(("lockfile" ,python2-lockfile)
- ("urllib3" ,python2-urllib3)))
+ `(("lockfile" ,python-lockfile)
+ ("urllib3" ,python-urllib3)))
(inputs
- `(("librsync" ,librsync-0.9)
+ `(("librsync" ,librsync)
("lftp" ,lftp)
("gnupg" ,gnupg) ; gpg executable needed
("util-linux" ,util-linux))) ; for setsid
(arguments
- `(#:python ,python-2 ; setup assumes Python 2
- #:test-target "test"
+ `(#:test-target "test"
#:phases
(modify-phases %standard-phases
(add-before 'build 'use-store-file-names
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "duplicity/gpginterface.py"
- (("self.call = 'gpg'")
+ (("self.call = u'gpg'")
(string-append "self.call = '" (assoc-ref inputs "gnupg") "/bin/gpg'")))
(substitute* '("testing/functional/__init__.py"
@@ -146,7 +151,7 @@ spying and/or modification by the server.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/Parchive/par2cmdline.git")
+ (url "https://github.com/Parchive/par2cmdline")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -310,7 +315,7 @@ random access nor for in-place modification.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/miekg/rdup.git")
+ (url "https://github.com/miekg/rdup")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -404,23 +409,24 @@ errors.")
(define-public rdiff-backup
(package
(name "rdiff-backup")
- (version "1.2.8")
+ (version "2.0.3")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://savannah/rdiff-backup/rdiff-backup-"
- version ".tar.gz"))
+ (uri (string-append "https://github.com/rdiff-backup/rdiff-backup/releases/"
+ "download/v" version "/rdiff-backup-" version ".tar.gz"))
(sha256
(base32
- "1nwmmh816f96h0ff1jxk95ad38ilbhbdl5dgibx1d4cl81dsi48d"))))
+ "1qfmvwwb942srhg6gw77ncy4z5z54b4wfz8bpd5bpml8hp1d5qh4"))))
(build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
(inputs
- `(("python" ,python-2)
- ("librsync" ,librsync-0.9)))
+ `(("python" ,python)
+ ("librsync" ,librsync)))
(arguments
- `(#:python ,python-2
- #:tests? #f))
- (home-page "https://www.nongnu.org/rdiff-backup/")
+ `(#:tests? #f)) ; Tests require root/sudo
+ (home-page "https://rdiff-backup.net/")
(synopsis "Local/remote mirroring+incremental backup")
(description
"Rdiff-backup backs up one directory to another, possibly over a network.
@@ -999,7 +1005,7 @@ precious backup space.
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/zbackup/zbackup.git")
+ (url "https://github.com/zbackup/zbackup")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -1053,12 +1059,12 @@ is format-agnostic, so you can feed virtually any files to it.")
("util-linux" ,util-linux "lib")
("e2fsprogs" ,e2fsprogs)))
(home-page "https://dump.sourceforge.io/")
- (synopsis "Ext2/3/4 filesystem dump/restore utilities")
- (description "Dump examines files in a filesystem, determines which ones
+ (synopsis "Ext2/3/4 file system dump/restore utilities")
+ (description "Dump examines files in a file system, determines which ones
need to be backed up, and copies those files to a specified disk, tape or
other storage medium. Subsequent incremental backups can then be layered on
top of the full backup. The restore command performs the inverse function of
-dump; it can restore a full backup of a filesystem. Single files and
+dump; it can restore a full backup of a file system. Single files and
directory subtrees may also be restored from full or partial backups in
interractive mode.")
(license license:bsd-3)))
@@ -1066,14 +1072,16 @@ interractive mode.")
(define-public burp
(package
(name "burp")
- (version "2.3.28")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/burp/burp-" version
- "/burp-" version ".tar.bz2"))
- (sha256
- (base32
- "18f8cjsb87skabvz4cl5pdln35qmim7x686js1xzpld6wyl9kv2k"))))
+ (version "2.3.30")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/grke/burp")
+ (commit version)))
+ (sha256
+ (base32 "1f9i5d415psbr03fqd47p162qy25sypra1w8w16ym6jk1pvdjsgx"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1086,12 +1094,15 @@ interractive mode.")
(string-append prefix " 3600" suffix "\n")))
#t)))))
(inputs
- `(("librsync" ,librsync)
+ `(("acl" ,acl)
+ ("librsync" ,librsync)
("openssl" ,openssl)
("uthash" ,uthash)
("zlib" ,zlib)))
(native-inputs
- `(("check" ,check)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("check" ,check)
("pkg-config" ,pkg-config)))
(home-page "https://burp.grke.org")
(synopsis "Differential backup and restore")