summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm61
1 files changed, 36 insertions, 25 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 7a1fd142bf..c8e6f175b1 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -55,6 +55,7 @@
#:use-module (gnu packages dbm)
#:use-module (gnu packages dejagnu)
#:use-module (gnu packages ftp)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
@@ -62,6 +63,7 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages linux)
#:use-module (gnu packages mcrypt)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages nettle)
#:use-module (gnu packages onc-rpc)
#:use-module (gnu packages pcre)
@@ -80,7 +82,7 @@
(define-public duplicity
(package
(name "duplicity")
- (version "0.7.19")
+ (version "0.8.15")
(source
(origin
(method url-fetch)
@@ -89,32 +91,36 @@
"-series/" version "/+download/duplicity-"
version ".tar.gz"))
(sha256
- (base32 "0ag9dknslxlasslwfjhqgcqbkb1mvzzx93ry7lch2lfzcdd91am6"))))
+ (base32 "1kg467mxg5a97v1rlv4shk32krgv8ys4nczq4b11av4bp1lgysdc"))))
(build-system python-build-system)
(native-inputs
- `(("util-linux" ,util-linux) ; setsid command, for the tests
+ `(("gettext" ,gnu-gettext) ; for msgfmt
+ ("util-linux" ,util-linux) ; setsid command, for the tests
("par2cmdline" ,par2cmdline)
- ("python-pexpect" ,python2-pexpect)
- ("python-fasteners" ,python2-fasteners)
+ ("python-fasteners" ,python-fasteners)
+ ("python-future" ,python-future) ; for tests
+ ("python-pexpect" ,python-pexpect)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-setuptools-scm" ,python-setuptools-scm)
("tzdata" ,tzdata-for-tests)
- ("mock" ,python2-mock)))
+ ("mock" ,python-mock)))
(propagated-inputs
- `(("lockfile" ,python2-lockfile)
- ("urllib3" ,python2-urllib3)))
+ `(("lockfile" ,python-lockfile)
+ ("urllib3" ,python-urllib3)))
(inputs
- `(("librsync" ,librsync-0.9)
+ `(("librsync" ,librsync)
("lftp" ,lftp)
("gnupg" ,gnupg) ; gpg executable needed
("util-linux" ,util-linux))) ; for setsid
(arguments
- `(#:python ,python-2 ; setup assumes Python 2
- #:test-target "test"
+ `(#:test-target "test"
#:phases
(modify-phases %standard-phases
(add-before 'build 'use-store-file-names
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "duplicity/gpginterface.py"
- (("self.call = 'gpg'")
+ (("self.call = u'gpg'")
(string-append "self.call = '" (assoc-ref inputs "gnupg") "/bin/gpg'")))
(substitute* '("testing/functional/__init__.py"
@@ -404,15 +410,14 @@ errors.")
(define-public rdiff-backup
(package
(name "rdiff-backup")
- (version "2.0.3")
+ (version "2.0.5")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/rdiff-backup/rdiff-backup/releases/"
"download/v" version "/rdiff-backup-" version ".tar.gz"))
(sha256
- (base32
- "1qfmvwwb942srhg6gw77ncy4z5z54b4wfz8bpd5bpml8hp1d5qh4"))))
+ (base32 "11rvjcp77zwgkphz1kyf5yqgr3rlss7dm9xzmvpvc4lp99xq7drb"))))
(build-system python-build-system)
(native-inputs
`(("python-setuptools-scm" ,python-setuptools-scm)))
@@ -1067,14 +1072,16 @@ interractive mode.")
(define-public burp
(package
(name "burp")
- (version "2.3.28")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/burp/burp-" version
- "/burp-" version ".tar.bz2"))
- (sha256
- (base32
- "18f8cjsb87skabvz4cl5pdln35qmim7x686js1xzpld6wyl9kv2k"))))
+ (version "2.3.32")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/grke/burp")
+ (commit version)))
+ (sha256
+ (base32 "0cxxf9ni34c9662ffmr2qc8xmh4g9pmg3swqvhn49mqgr5ra6k2g"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1087,12 +1094,16 @@ interractive mode.")
(string-append prefix " 3600" suffix "\n")))
#t)))))
(inputs
- `(("librsync" ,librsync)
+ `(("acl" ,acl)
+ ("librsync" ,librsync)
+ ("ncurses" ,ncurses) ; for the live status monitor
("openssl" ,openssl)
("uthash" ,uthash)
("zlib" ,zlib)))
(native-inputs
- `(("check" ,check)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("check" ,check)
("pkg-config" ,pkg-config)))
(home-page "https://burp.grke.org")
(synopsis "Differential backup and restore")