summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm135
1 files changed, 105 insertions, 30 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index b429aeb107..803efb5cd1 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -78,6 +78,7 @@
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
+ #:use-module (gnu packages man)
#:use-module (gnu packages maths)
#:use-module (gnu packages mp3) ;taglib
#:use-module (gnu packages multiprecision)
@@ -1443,7 +1444,7 @@ patches that can be used with softsynths such as Timidity and WildMidi.")
(list (search-path-specification
(variable "LV2_PATH")
(files '("lib/lv2")))))
- (home-page "http://guitarix.org/")
+ (home-page "https://guitarix.org/")
(synopsis "Virtual guitar amplifier")
(description "Guitarix is a virtual guitar amplifier running JACK.
Guitarix takes the signal from your guitar as a mono-signal from your sound
@@ -3271,14 +3272,14 @@ with support for HD extensions.")
(define-public bs1770gain
(package
(name "bs1770gain")
- (version "0.6.5")
+ (version "0.6.7")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/bs1770gain/bs1770gain/"
version "/bs1770gain-" version ".tar.gz"))
(sha256
- (base32 "15nvlh9bg0a52cpg2mii17mlzmxszwivjjalbb4np1v5nj8l5fk6"))
+ (base32 "13hsbqj1dkpz1gbclnjxv50kr7b4gcjai6c1l38g01433h217qjc"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -3699,38 +3700,35 @@ using ALSA, MPD, PulseAudio, or a FIFO buffer as its input.")
(license license:expat))))
(define-public libfdk
- (let ((commit "2326faaf8f2cdf2c3a9108ccdaf1d7551aec543e")
- (revision "0"))
- (package
- (name "libfdk")
- ;; The latest upstream revision, with many bug fixes.
- (version (git-version "0.1.6" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mstorsjo/fdk-aac")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0yy6ndd9d61bwl283vl1r5kva2a4acc0f4r9g0sza156f2abr9ws"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
- (home-page "https://github.com/mstorsjo/fdk-aac")
- (synopsis "Fraunhofer FDK AAC library")
- (description "FDK is a library for encoding and decoding Advanced Audio
+ (package
+ (name "libfdk")
+ (version "2.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mstorsjo/fdk-aac")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1fkrnzs78fmj11n9z3l0w53i2fl16jcfiyavwidck9bzmkmsf486"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (home-page "https://github.com/mstorsjo/fdk-aac")
+ (synopsis "Fraunhofer FDK AAC library")
+ (description "FDK is a library for encoding and decoding Advanced Audio
Coding (AAC) format audio, developed by Fraunhofer IIS, and included as part of
Android. It supports several Audio Object Types including MPEG-2 and MPEG-4 AAC
LC, HE-AAC (AAC LC + SBR), HE-AACv2 (LC + SBR + PS) as well AAC-LD (low delay)
and AAC-ELD (enhanced low delay) for real-time communication. The encoding
library supports sample rates up to 96 kHz and up to eight channels (7.1
-surround).")
- (license (license:fsf-free "https://github.com/mstorsjo/fdk-aac/blob/master/NOTICE"
- "https://www.gnu.org/licenses/license-list.html#fdk")))))
+ surround).")
+ (license (license:fsf-free "https://github.com/mstorsjo/fdk-aac/blob/master/NOTICE"
+ "https://www.gnu.org/licenses/license-list.html#fdk"))))
(define-public libopenshot-audio
(package
@@ -4084,3 +4082,80 @@ given plugin and its UI(s) match up with the provided metadata and adhere
to well-known best practices.")
(home-page "https://open-music-kontrollers.ch/lv2/lv2lint/")
(license license:artistic2.0)))
+
+(define-public lv2toweb
+ (package
+ (name "lv2toweb")
+ (version "0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/x42/lv2toweb")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "007aysqvgkf25za8nkmyd5g9kp1zla460dcpidlj5xg1zc3fcdfi"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("jalv", jalv)
+ ("lilv", lilv)))
+ (native-inputs
+ `(("help2man", help2man)
+ ("pkg-config", pkg-config)))
+ (synopsis "Documentation generator for LV2 plugins")
+ (description
+ "lv2toweb allows the user to create an xhtml page with information
+about the given LV2 plugin, provided that the plugin and its UI(s) match up
+with the provided metadata and adhere to well-known best practices.")
+ (home-page "https://github.com/x42/lv2toweb")
+ (license (list license:isc license:gpl2))))
+
+(define-public ztoolkit
+ (package
+ (name "ztoolkit")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.zrythm.org/git/ztoolkit")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07xl3cmdaf7k9mm58m93cn8i1jvgimmiifdw1w7v2jl88nx60pm1"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("cairo" ,cairo)
+ ("libx11" ,libx11)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "GUI toolkit for LV2 plugins")
+ (description "ZToolkit (Ztk) is a cross-platform GUI toolkit heavily
+inspired by GTK. It handles events and low level drawing on behalf of
+the user and provides a high-level API for managing the UI and custom
+widgets. ZToolkit is written in C and was created to be used for building
+audio plugin UIs, where the dependencies often need to be kept to a
+minimum.")
+ (home-page "https://git.zrythm.org/cgit/ztoolkit/")
+ (license license:agpl3+)))
+
+(define-public ztoolkit-rsvg
+ (package
+ (inherit ztoolkit)
+ (name "ztoolkit-rsvg")
+ (arguments
+ `(#:configure-flags `("-Denable_rsvg=true")))
+ (inputs
+ `(("librsvg" ,librsvg)
+ ,@(package-inputs ztoolkit)))
+ (synopsis "ZToolkit with SVG support")))