summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm129
1 files changed, 107 insertions, 22 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 38ee4f8bcc..8a0c0fce2b 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2020 Jonathan Frederickson <jonathan@terracrypt.net>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1046,7 +1047,7 @@ tools (analyzer, mono/stereo tools, crossovers).")
`(("lv2" ,lv2)))
;; home-page of the original LADSPA version: http://quitte.de/dsp/caps.html
(home-page "https://github.com/moddevices/caps-lv2")
- (synopsis "LV2 port of the CAPS audio plugin colection")
+ (synopsis "LV2 port of the CAPS audio plugin collection")
(description
"LV2 port of CAPS, a collection of audio plugins comprising basic virtual
guitar amplification and a small range of classic effects, signal processors and
@@ -1631,7 +1632,7 @@ follower.")
(define-public fluidsynth
(package
(name "fluidsynth")
- (version "2.1.4")
+ (version "2.1.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1640,7 +1641,7 @@ follower.")
(file-name (git-file-name name version))
(sha256
(base32
- "1r3khwyw57ybg5m4x0rvdzq7hgw2484sd52k6bm19akbw8yicfna"))))
+ "0ccpq4p1h1g53ng3961g3lh590qnwvpzwdzpl6ai4j6iazq0bh73"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; no check target
@@ -2030,7 +2031,7 @@ synchronous execution of all clients, and low latency operation.")
(define-public jack-2
(package (inherit jack-1)
(name "jack2")
- (version "1.9.13")
+ (version "1.9.14")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/jackaudio/jack2/releases/"
@@ -2039,7 +2040,7 @@ synchronous execution of all clients, and low latency operation.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1d1d403jn4366mqig6g8ghr8057b3rn7gs26b5p3rkal34j20qw2"))))
+ "0z11hf55a6mi8h50hfz5wry9pshlwl4mzfwgslghdh40cwv342m2"))))
(build-system waf-build-system)
(arguments
`(#:tests? #f ; no check target
@@ -2049,6 +2050,10 @@ synchronous execution of all clients, and low latency operation.")
(modify-phases %standard-phases
(add-before 'configure 'set-linkflags
(lambda _
+ ;; Ensure -lstdc++ is the tail of LDFLAGS or the simdtests.cpp
+ ;; will not link with undefined reference to symbol
+ ;; '__gxx_personality_v0@@CXXABI_1.3'
+ (setenv "LDFLAGS" "-lstdc++")
;; Add $libdir to the RUNPATH of all the binaries.
(substitute* "wscript"
((".*CFLAGS.*-Wall.*" m)
@@ -2676,20 +2681,21 @@ different audio devices such as ALSA or PulseAudio.")
(define-public qjackctl
(package
(name "qjackctl")
- (version "0.5.9")
+ (version "0.6.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/qjackctl/qjackctl/"
version "/qjackctl-" version ".tar.gz"))
(sha256
(base32
- "1saywsda9m124rmjp7i3n0llryaliabjxhqhvqr6dm983qy7pypk"))))
+ "0zbb4jlx56qvcqyhx34mbagkqf3wbxgj84hk0ppf5cmcrxv67d4x"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f)) ; no check target
(inputs
`(("jack" ,jack-1)
("alsa-lib" ,alsa-lib)
+ ("portaudio" ,portaudio)
("qtbase" ,qtbase)
("qtx11extras" ,qtx11extras)))
(native-inputs
@@ -3054,6 +3060,32 @@ that toolkit will work in all hosts that use Suil automatically.
Suil currently supports every combination of Gtk, Qt, and X11.")
(license license:isc)))
+(define-public libebur128
+ (package
+ (name "libebur128")
+ (version "1.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jiixyj/libebur128")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0n81rnm8dm1zmibkr2v3q79rsd609y0dbbsrbay18njcjva88p0g"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(;; Tests require proprietary .wav files. See
+ ;; https://github.com/jiixyj/libebur128/issues/82.
+ #:tests? #f
+ #:configure-flags '("-DBUILD_STATIC_LIBS=OFF")))
+ (home-page "https://github.com/jiixyj/libebur128")
+ (synopsis "Library implementing the EBU R 128 loudness standard")
+ (description
+ "@code{libebur128} is a C library that implements the EBU R 128 standard
+for loudness normalisation.")
+ (license license:expat)))
+
(define-public timidity++
(package
(name "timidity++")
@@ -3298,7 +3330,7 @@ Tracker 3 S3M and Impulse Tracker IT files.")
(define-public soundtouch
(package
(name "soundtouch")
- (version "2.1.2")
+ (version "2.2")
(source
(origin
(method git-fetch)
@@ -3307,7 +3339,7 @@ Tracker 3 S3M and Impulse Tracker IT files.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "174wgm3s0inmbnkrlnspxjwm2014qhjhkbdqa5r8rbfi0nzqxzsz"))))
+ (base32 "12i6yg8vvqwyk412lxl2krbfby6hnxld8qxy0k4m5xp4g94jiq4p"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -3959,10 +3991,31 @@ mixers.")
(define-public python2-pyalsaaudio
(package-with-python2 python-pyalsaaudio))
+(define-public ldacbt
+ (package
+ (name "ldacbt")
+ (version "2.0.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/EHfive/ldacBT"
+ "/releases/download/v" version
+ "/ldacBT-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1d65dms4klzql29abi15i90f41h523kl6mxrz9hi6p5vg37fxn2b"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; no check target
+ (home-page "https://github.com/EHfive/ldacBT/")
+ (synopsis "LDAC Bluetooth encoder and ABR library")
+ (description "This package provides an encoder for the LDAC
+high-resolution Bluetooth audio streaming codec for streaming at up to 990
+kbps at 24 bit/96 kHz.")
+ (license license:asl2.0)))
+
(define-public bluez-alsa
(package
(name "bluez-alsa")
- (version "2.0.0")
+ (version "3.0.0")
(source (origin
;; The tarballs are mere snapshots and don't contain a
;; bootstrapped build system.
@@ -3973,11 +4026,12 @@ mixers.")
(file-name (git-file-name name version))
(sha256
(base32
- "08mppgnjf1j2733bk9yf0cny6rfxxwiys0s62lz2zd2lpdl6d9lz"))))
+ "1jlsgxyqfhncfhx1sy3ry0dp6p95kd4agh7g2b7g51h0c4cv74h8"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
- (list (string-append "--with-alsaplugindir="
+ (list "--enable-ldac"
+ (string-append "--with-alsaplugindir="
(assoc-ref %outputs "out")
"/lib/alsa-lib")
(string-append "--with-dbusconfdir="
@@ -3993,6 +4047,7 @@ mixers.")
("bluez" ,bluez)
("dbus" ,dbus)
("glib" ,glib)
+ ("ldacbt" ,ldacbt)
("libbsd" ,libbsd)
("ncurses" ,ncurses)
("ortp" ,ortp)
@@ -4464,6 +4519,36 @@ supports both of ID3v1/v2 and APEv2 tags.")
(home-page "http://tausoft.org/")
(license license:gpl2+)))
+(define-public libsoundio
+ (package
+ (name "libsoundio")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/andrewrk/libsoundio")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12l4rvaypv87vigdrmjz48d4d6sq4gfxf5asvnc4adyabxb73i4x"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;no tests included
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("jack" ,jack-1)
+ ("pulseaudio" ,pulseaudio)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://libsound.io")
+ (synopsis "C library for real-time audio input and output")
+ (description "@code{libsoundio} is a C library providing audio input and
+output. The API is suitable for real-time software such as digital audio
+workstations as well as consumer software such as music players.")
+ (license license:expat)))
+
(define-public redkite
(package
(name "redkite")
@@ -4483,7 +4568,7 @@ supports both of ID3v1/v2 and APEv2 tags.")
(inputs
`(("cairo" ,cairo)))
(native-inputs
- `(("pkg-config", pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(synopsis "Small GUI toolkit")
(description "Redkite is a small GUI toolkit developed in C++17 and
inspired from other well known GUI toolkits such as Qt and GTK. It is
@@ -4629,7 +4714,7 @@ in the package.")
`(("libsamplerate" ,libsamplerate)
("libsndfile" ,libsndfile)))
(native-inputs
- `(("pkg-config", pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(synopsis "Library for reading and resampling audio files")
(description "libaudec is a wrapper library over ffmpeg, sndfile and
libsamplerate for reading and resampling audio files, based on Robin Gareus'
@@ -4657,11 +4742,11 @@ libsamplerate for reading and resampling audio files, based on Robin Gareus'
`("-Delf-tests=true" ; for checking symbol visibility
"-Donline-tests=true"))) ; for checking URI existence
(inputs
- `(("curl", curl)
- ("libelf", libelf)
- ("lilv", lilv)))
+ `(("curl" ,curl)
+ ("libelf" ,libelf)
+ ("lilv" ,lilv)))
(native-inputs
- `(("pkg-config", pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(synopsis "LV2 plugin lint tool")
(description "lv2lint is an LV2 lint-like tool that checks whether a
given plugin and its UI(s) match up with the provided metadata and adhere
@@ -4692,11 +4777,11 @@ to well-known best practices.")
(modify-phases %standard-phases
(delete 'configure))))
(inputs
- `(("jalv", jalv)
- ("lilv", lilv)))
+ `(("jalv" ,jalv)
+ ("lilv" ,lilv)))
(native-inputs
- `(("help2man", help2man)
- ("pkg-config", pkg-config)))
+ `(("help2man" ,help2man)
+ ("pkg-config" ,pkg-config)))
(synopsis "Documentation generator for LV2 plugins")
(description
"lv2toweb allows the user to create an xhtml page with information