summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm36
1 files changed, 10 insertions, 26 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3c5b6307eb..db7076b003 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -76,6 +76,7 @@
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages onc-rpc)
#:use-module (gnu packages qt)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages linux)
@@ -1595,15 +1596,7 @@ synchronous execution of all clients, and low latency operation.")
(build-system waf-build-system)
(arguments
`(#:tests? #f ; no check target
- #:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (add-before
- 'configure 'set-flags
- (lambda _
- ;; Compile with C++11, required by gtkmm.
- (setenv "CXXFLAGS" "-std=c++11")
- #t)))))
+ #:python ,python-2))
(inputs
`(("lv2" ,lv2)
("lilv" ,lilv)
@@ -1684,7 +1677,12 @@ to be plugged into a wide range of audio synthesis and recording packages.")
"12z1vx3krrzsfccpah9xjs68900xvr7bw92wx8np5871i2yv47iw"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ '(;; Glibc no longer includes Sun RPC support, so tell the build system
+ ;; to use libtirpc instead.
+ #:make-flags (list (string-append "CFLAGS=-I"
+ (assoc-ref %build-inputs "libtirpc")
+ "/include/tirpc -ltirpc"))
+ #:phases
(modify-phases %standard-phases
;; lashd embeds an ancient version of sigsegv so we just skip it
(add-after 'unpack 'skip-lashd
@@ -1697,6 +1695,7 @@ to be plugged into a wide range of audio synthesis and recording packages.")
`(("bdb" ,bdb)
("gtk" ,gtk+-2)
("jack" ,jack-1)
+ ("libtirpc" ,libtirpc)
("readline" ,readline)
("python" ,python-2)))
;; According to pkg-config, packages depending on lash also need to have
@@ -1949,22 +1948,7 @@ software.")
#:configure-flags
(list (string-append "--boost-includes="
(assoc-ref %build-inputs "boost")
- "/include"))
- #:phases (modify-phases %standard-phases
- (add-before
- 'configure 'set-flags
- (lambda* (#:key inputs #:allow-other-keys)
- ;; See e.g. https://github.com/lvtk/lvtk/issues/21
- (setenv "LDFLAGS"
- (string-append
- "-L" (assoc-ref inputs "boost") "/lib "
- "-lboost_system"))
- ;; Needed for gtkmm
- (substitute* '("src/wscript_build"
- "examples/wscript_build")
- (("cxxflags.*= \\[" line)
- (string-append line "\"-std=c++11\", ")))
- #t)))))
+ "/include"))))
(inputs
`(("boost" ,boost)
("gtkmm" ,gtkmm-2)