summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm43
1 files changed, 22 insertions, 21 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 017f1ec74e..eae0d1fe68 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2016, 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
-;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 okapi <okapi@firemail.cc>
;;; Copyright © 2018, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -136,6 +136,7 @@
#:use-module (guix build-system waf)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
@@ -2869,14 +2870,14 @@ different audio devices such as ALSA or PulseAudio.")
(define-public qjackctl
(package
(name "qjackctl")
- (version "0.9.5")
+ (version "0.9.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/qjackctl/qjackctl/"
version "/qjackctl-" version ".tar.gz"))
(sha256
(base32
- "1g61xwsxsndwlnh4547vl7jfcf4kqlbb4394jq2m8qbbzk51b6rv"))))
+ "0sqni9ppwadc01fnyqj6lkwy30ql1vccqglv9imd3zdchffjpjir"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f)) ; no check target
@@ -3414,7 +3415,7 @@ stretching and pitch scaling of audio. This package contains the library.")
(define-public libkeyfinder
(package
(name "libkeyfinder")
- (version "2.2.5")
+ (version "2.2.6")
(source
(origin
(method git-fetch)
@@ -3423,7 +3424,7 @@ stretching and pitch scaling of audio. This package contains the library.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1623kirmxhmvmhx7f8lbzk0f18w2hrhwlkzl8l4aa906lfqffdp2"))))
+ (base32 "0s7nqjmv44q5qjynfcs0j6h4a6qcz4mxzandkkdjjbnwv5rxc3zg"))))
(build-system cmake-build-system)
(native-inputs
(list catch-framework2))
@@ -5119,7 +5120,7 @@ edited, converted, compressed and saved.")
(define-public lsp-dsp-lib
(package
(name "lsp-dsp-lib")
- (version "0.5.11")
+ (version "0.5.14")
(source
(origin
(method url-fetch)
@@ -5127,23 +5128,23 @@ edited, converted, compressed and saved.")
"releases/download/" version
"/lsp-dsp-lib-" version "-src.tar.gz"))
(sha256
- (base32 "0lkar6r9jfrrqswi8nnndlm5a9kfwqjn92d81gp2yhc3p46xsswz"))))
+ (base32 "1gcznkyybywbgdi2fhx27i8sckhy6ahvxax72b213g1lr5aaw7bq"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:make-flags
- (list (string-append "CC=" ,(cc-for-target)))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'omit-static-library
- (lambda _
- (substitute* "src/Makefile"
- ((".*@.*ARTIFACT_SLIB.*") "") ; don't install it
- ((" \\$\\(ARTIFACT_SLIB\\)") "")))) ; don't build it
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "make" "config"
- (string-append "PREFIX=" (assoc-ref outputs "out"))))))))
+ (list #:tests? #f ; no tests
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'omit-static-library
+ (lambda _
+ (substitute* "src/Makefile"
+ ((".*cp \\$\\(ARTIFACT_SLIB\\).*") "") ; don't install it
+ ((" \\$\\(ARTIFACT_SLIB\\)") "")))) ; don't build it
+ (replace 'configure
+ (lambda _
+ (invoke "make" "config"
+ (string-append "PREFIX=" #$output)))))))
(home-page "https://github.com/sadko4u/lsp-dsp-lib")
(synopsis "Digital signal processing library")
(description "The LSP DSP library provides a set of functions that perform