summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm99
1 files changed, 86 insertions, 13 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 9ddb9e1d52..81c7481e0b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 by Amar Singh <nly@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,17 +23,27 @@
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (gnu packages autotools)
#:use-module (gnu packages image)
#:use-module (gnu packages compression)
#:use-module (gnu packages gettext)
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages xiph)
+ #:use-module (gnu packages pretty-print)
+ #:use-module (gnu packages algebra)
+ #:use-module (gnu packages lua)
#:use-module (gnu packages perl)
#:use-module (gnu packages gl)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages maths)
#:use-module (guix build-system cmake)
- #:use-module (guix build-system gnu))
+ #:use-module (guix build-system gnu)
+ #:use-module (srfi srfi-1))
(define-public cfitsio
(package
@@ -133,15 +144,15 @@ programs for the manipulation and analysis of astronomical data.")
(define-public stellarium
(package
(name "stellarium")
- (version "0.19.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/Stellarium/" name
- "/releases/download/v" version
- "/" name "-" version ".tar.gz"))
- (sha256
- (base32
- "1mjjqcpgm5a1022x0mpqj3v6qkvpm9wqm1hqyg0mlypc5681va8a"))))
+ (version "0.19.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Stellarium/stellarium"
+ "/releases/download/v" version
+ "/stellarium-" version ".tar.gz"))
+ (sha256
+ (base32 "0s7v5iyhah258k83kvy2a91a3mdf34r150lcar4mmdsrrcmas98g"))))
(build-system cmake-build-system)
(inputs
`(("qtbase" ,qtbase)
@@ -151,9 +162,9 @@ programs for the manipulation and analysis of astronomical data.")
("qtserialport" ,qtserialport)
("zlib" ,zlib)))
(native-inputs
- `(("gettext" ,gettext-minimal) ; xgettext is used at compile time
- ("perl" ,perl) ; For pod2man
- ("qtbase" ,qtbase) ; Qt MOC is needed at compile time
+ `(("gettext" ,gettext-minimal) ; xgettext is used at compile time
+ ("perl" ,perl) ; For pod2man
+ ("qtbase" ,qtbase) ; Qt MOC is needed at compile time
("qttools" ,qttools)))
(arguments
`(#:test-target "test"
@@ -176,3 +187,65 @@ programs for the manipulation and analysis of astronomical data.")
can be used to control telescopes over a serial port for tracking celestial
objects.")
(license license:gpl2+)))
+
+(define-public celestia
+ (let ((commit "9dbdf29c4ac3d20afb2d9a80d3dff241ecf81dce"))
+ (package
+ (name "celestia")
+ (version (git-version "1.6.1" "815" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/celestiaproject/celestia")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00xibg87l1arzifakgj7s828x9pszcgx7x7ij88a561ig49ryh78"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("perl" ,perl)
+ ("libgit2" ,libgit2)
+ ("pkg-config" ,pkg-config)
+ ("libtool" ,libtool)
+ ("gettext" ,gettext-minimal)))
+ (inputs
+ `(("glu" ,glu)
+ ("glew" ,glew)
+ ("libtheora" ,libtheora)
+ ("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ;; maybe required?
+ ("mesa" ,mesa)
+ ;; optional: fmtlib, Eigen3;
+ ("fmt" ,fmt)
+ ("eigen" ,eigen)
+ ;; glut: for glut interface
+ ("freeglut" ,freeglut)))
+ (propagated-inputs
+ `(("lua" ,lua)))
+ (arguments
+ `(#:configure-flags '("-DENABLE_GLUT=ON" "-DENABLE_QT=OFF")
+ #:tests? #f)) ;no tests
+ (home-page "https://celestia.space/")
+ (synopsis "Real-time 3D visualization of space")
+ (description
+ "This simulation program lets you explore our universe in three
+dimensions. Celestia simulates many different types of celestial objects.
+From planets and moons to star clusters and galaxies, you can visit every
+object in the expandable database and view it from any point in space and
+time. The position and movement of solar system objects is calculated
+accurately in real time at any rate desired.")
+ (license license:gpl2+))))
+
+(define-public celestia-gtk
+ (package
+ (inherit celestia)
+ (name "celestia-gtk")
+ (inputs
+ (append (alist-delete "freeglut" (package-inputs celestia))
+ `(("gtk2" ,gtk+-2)
+ ("gtkglext" ,gtkglext))))
+ (arguments
+ `(#:configure-flags '("-DENABLE_GTK=ON" "-DENABLE_QT=OFF")
+ #:tests? #f))))