summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm49
1 files changed, 26 insertions, 23 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d21c093876..c3a591baa3 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -64,7 +65,7 @@ in FITS files.")
(define-public wcslib
(package
(name "wcslib")
- (version "5.17")
+ (version "5.18")
(source
(origin
(method url-fetch)
@@ -72,7 +73,7 @@ in FITS files.")
"ftp://ftp.atnf.csiro.au/pub/software/wcslib/" name "-" version
".tar.bz2"))
(sha256
- (base32 "0v23x1fw01arhmqdrzfd9n593mjglhzfyx4793v065z0dg4bb72w"))))
+ (base32 "16jh568k99c9p0y3qzcgps2rii933x9wlay7q1xm0lr59zqzp4xn"))))
(inputs
`(("cfitsio" ,cfitsio)))
(build-system gnu-build-system)
@@ -85,9 +86,10 @@ in FITS files.")
#t)))))
(home-page "https://www.atnf.csiro.au/people/mcalabre/WCS")
(synopsis "Library which implements the FITS WCS standard")
- (description "The FITS \"World Coordinate System\" (WCS) standard defines
-keywords and usage that provide for the description of astronomical coordinate
-systems in a FITS image header.")
+ (description "The FITS \"World Coordinate System\" (@dfn{WCS}) standard
+defines keywords and usage that provide for the description of astronomical
+coordinate systems in a @dfn{FITS} (Flexible Image Transport System) image
+header.")
(license license:lgpl3+)))
(define-public gnuastro
@@ -117,15 +119,16 @@ programs for the manipulation and analysis of astronomical data.")
(define-public stellarium
(package
(name "stellarium")
- (version "0.16.0")
+ (version "0.17.0")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/stellarium/"
- "Stellarium-sources/"
- version "/stellarium-" version ".tar.gz"))
+ (uri (string-append "https://github.com/Stellarium/" name
+ "/releases/download/v" version
+ "/" name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1krxj51lix096xbz64lys166a8zdwhill5vvs7dlxdn14amc8d98"))))
+ "0d6b3fs5aify7i1lwgkcickppnj73cbh24g8qschnfs3ypdf48fc"))))
(build-system cmake-build-system)
(inputs
`(("qtbase" ,qtbase)
@@ -140,19 +143,19 @@ programs for the manipulation and analysis of astronomical data.")
("qtbase" ,qtbase) ; Qt MOC is needed at compile time
("qttools" ,qttools)))
(arguments
- `(#:test-target "tests"
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'patch-tests
- (lambda _
- (substitute* "src/tests/testStelSphereGeometry.cpp"
- (("Vec3d v[(]0[)]") "Vec3d v(0.0)"))
- #t))
- (add-before 'check 'set-offscreen-display
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "HOME" "/tmp")
- #t)))))
+ `(#:test-target "test"
+ #:configure-flags (list "-DENABLE_TESTING=1"
+ (string-append
+ "-DCMAKE_CXX_FLAGS=-isystem "
+ (assoc-ref %build-inputs "qtserialport")
+ "/include/qt5"))
+ #:phases (modify-phases %standard-phases
+ (add-before 'check 'set-offscreen-display
+ (lambda _
+ ;; make Qt render "offscreen", required for tests
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "HOME" "/tmp")
+ #t)))))
(home-page "http://www.stellarium.org/")
(synopsis "3D sky viewer")
(description "Stellarium is a planetarium. It shows a realistic sky in