summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm314
1 files changed, 310 insertions, 4 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 07dee4b462..f623274136 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -48,9 +48,13 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pretty-print)
+ #:use-module (gnu packages python-check)
+ #:use-module (gnu packages python-crypto)
+ #:use-module (gnu packages python-science)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages version-control)
+ #:use-module (gnu packages video)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xorg)
#:use-module (guix build-system cmake)
@@ -92,6 +96,51 @@ in FITS files.")
(license (license:non-copyleft "file://License.txt"
"See License.txt in the distribution."))))
+(define-public qfits
+ (package
+ (name "qfits")
+ (version "6.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "ftp://ftp.eso.org/pub/qfits/qfits-" version ".tar.gz"))
+ (sha256
+ (base32 "0m2b21mim3a7wgfg3ph2w5hv7mdvr03jmmhzipc0wcahijglcw9j"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.eso.org/sci/software/eclipse/qfits/")
+ (synopsis "C library offering access to astronomical FITS files")
+ (description
+ "@code{qfits} is a C library giving access to FITS file internals, both
+for reading and writing.")
+ (license license:gpl2+)))
+
+(define-public erfa
+ (package
+ (name "erfa")
+ (version "1.7.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/liberfa/erfa")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vsqwvzlk7r8q7nwyb7i710blcfdl5kwcm2va9km07a820nsp84a"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoreconf" ,autoconf)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/liberfa/erfa")
+ (synopsis "Essential Routines for Fundamental Astronomy")
+ (description
+ "ERFA is a C library containing key algorithms for astronomy, and is based
+on the SOFA library published by the International Astronomical Union (IAU).")
+ (license license:bsd-3)))
+
(define-public eye
(package
(name "eye")
@@ -118,7 +167,7 @@ feature detection and cosmetic corrections.")
(define-public wcslib
(package
(name "wcslib")
- (version "6.4")
+ (version "7.4")
(source
(origin
(method url-fetch)
@@ -126,7 +175,7 @@ feature detection and cosmetic corrections.")
"ftp://ftp.atnf.csiro.au/pub/software/wcslib/wcslib-" version
".tar.bz2"))
(sha256
- (base32 "003h23m6d5wcs29v2vbnl63f3z35k5x70lpsqlz5c9bp1bvizh8k"))))
+ (base32 "072i1id4zk08mwi2c1zpy8zxrabl8dqyklx9ikbd2nh56r0rc752"))))
(inputs
`(("cfitsio" ,cfitsio)))
(build-system gnu-build-system)
@@ -283,6 +332,70 @@ astronomical fields. SkyMaker is part of the EFIGI
(@url{https://www.astromatic.net/projects/efigi}) development project.")
(license license:gpl3+)))
+(define-public stackistry
+ (package
+ (name "stackistry")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/GreatAttractor/stackistry")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rz29v33n0x0k40hv3v79ym5ylch1v0pbph4i21809gz2al5p7dq"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list
+ (string-append
+ "SKRY_INCLUDE_PATH=" (assoc-ref %build-inputs "libskry") "/include")
+ (string-append
+ "SKRY_LIB_PATH=-L" (assoc-ref %build-inputs "libskry") "/lib")
+ (string-append
+ "LIBAV_INCLUDE_PATH=" (assoc-ref %build-inputs "ffmpeg") "/include"))
+ #:phases
+ (modify-phases %standard-phases
+ ;; no configure and tests are provided
+ (delete 'configure)
+ (delete 'check)
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "src/main.cpp"
+ (("\"\\.\\.\", \"lang\"")
+ "\"../share/stackistry\", \"lang\""))
+ (substitute* "src/utils.cpp"
+ (("\"\\.\\.\", \"icons\"")
+ "\"../share/stackistry\", \"icons\""))
+ #t))
+ (replace 'install
+ ;; The Makefile lacks an ‘install’ target.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (icons (string-append out "/share/stackistry/icons"))
+ (lang (string-append out "/share/stackistry/lang")))
+ (copy-recursively "bin" bin)
+ (copy-recursively "icons" icons)
+ (copy-recursively "lang" lang))
+ #t)))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtkmm" ,gtkmm)
+ ("libskry" ,libskry)
+ ("ffmpeg" ,ffmpeg)))
+ (home-page "https://github.com/GreatAttractor/stackistry")
+ (synopsis "Astronomical lucky imaging/image stacking tool")
+ (description
+ "Stackistry implements the lucky imaging principle of astronomical
+imaging: creating a high-quality still image out of a series of many (possibly
+thousands) low quality ones (blurred, deformed, noisy). The resulting image
+stack typically requires post-processing, including sharpening (e.g. via
+deconvolution). Such post-processing is not performed by Stackistry.")
+ (license license:gpl3+)))
+
(define-public stellarium
(package
(name "stellarium")
@@ -466,6 +579,48 @@ Mechanics, Astrometry and Astrodynamics library.")
(license (list license:lgpl2.0+
license:gpl2+)))) ; examples/transforms.c & lntest/*.c
+(define-public libskry
+ (package
+ (name "libskry")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/GreatAttractor/libskry")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14kwng0j8wqzlb0gqg3ayq36l15dpz7kvxc56fa47j55b376bwh6"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list
+ (string-append
+ "LIBAV_INCLUDE_PATH=" (assoc-ref %build-inputs "ffmpeg") "/include"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ;; no configure provided
+ (delete 'check) ;; no tests provided
+ (replace 'install
+ ;; The Makefile lacks an ‘install’ target.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib"))
+ (include (string-append out "/include")))
+ (copy-recursively "bin" lib)
+ (copy-recursively "include" include))
+ #t)))))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)))
+ (home-page "https://github.com/GreatAttractor/libskry")
+ (synopsis "Astronimical lucky imaging library")
+ (description
+ "@code{libskry} implements the lucky imaging principle of astronomical
+imaging: creating a high-quality still image out of a series of many thousands)
+low quality ones")
+ (license license:gpl3+)))
+
(define-public libpasastro
;; NOTE: (Sharlatan-20210122T215921+0000): the version tag has a build
;; error on spice which is resolved with the latest commit.
@@ -638,7 +793,7 @@ provide you with detailed information about each pass.")
(define-public indi
(package
(name "indi")
- (version "1.8.8")
+ (version "1.8.9")
(source
(origin
(method git-fetch)
@@ -647,7 +802,7 @@ provide you with detailed information about each pass.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "19gm7rbnm3295g2i8mdzfslpz0vrcgfmbl59311qpszvlxbmyd2r"))))
+ (base32 "0nw4b2cdsg244slcm3yf1v11jlxbbjrpvi6ax90svs7rlandz8jv"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
@@ -726,3 +881,154 @@ more.")
"The package is a Python implementation of the mathematics that standard
JPL ephemerides use to predict raw (x,y,z) planetary positions.")
(license license:expat)))
+
+(define-public python-pyerfa
+ (package
+ (name "python-pyerfa")
+ (version "1.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyerfa" version))
+ (sha256
+ (base32 "1s78mdyrxha2jcckfs0wg5ynkf0pwh1bw9mmh99vprinxh9n4xri"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove bundled submodule library.
+ (delete-file-recursively "liberfa")
+ #t))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'use-system-liberfa
+ (lambda _
+ (setenv "PYERFA_USE_SYSTEM_LIBERFA" "1")
+ #t)))))
+ (native-inputs
+ `(("pytest" ,python-pytest)
+ ("setuptools-scm" ,python-setuptools-scm)
+ ("pytest-doctestplus" ,python-pytest-doctestplus)))
+ (inputs
+ `(("liberfa" ,erfa)
+ ("numpy" ,python-numpy)))
+ (home-page "https://github.com/liberfa/pyerfa")
+ (synopsis "Python bindings for ERFA")
+ (description
+ "PyERFA is the Python wrapper for the ERFA library (Essential
+Routines for Fundamental Astronomy), a C library containing key algorithms for
+astronomy, which is based on the SOFA library published by the International
+Astronomical Union (IAU). All C routines are wrapped as Numpy universal
+functions, so that they can be called with scalar or array inputs.")
+ (license license:bsd-3)))
+
+(define-public python-sep
+ (package
+ (name "python-sep")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sep" version))
+ (sha256
+ (base32 "0wxdqn92q1grv8k7xi7h88ac6wnznw4xh5bdlz1vz6za2dgsyj4m"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("cython" ,python-cython)
+ ("pytest" ,python-pytest)))
+ (inputs
+ `(("numpy" ,python-numpy)))
+ (home-page "https://github.com/kbarbary/sep")
+ (synopsis "Astronomical source extraction and photometry library")
+ (description
+ "SEP makes the core algorithms of Source Extractor available as a library
+of stand-alone functions and classes.")
+ (license (list license:bsd-3
+ license:expat
+ license:lgpl3+))))
+
+(define-public python-asdf
+ (package
+ (name "python-asdf")
+ (version "2.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "asdf" version))
+ (sha256
+ (base32 "1y47zhkd90i8wmm2i35amfl0rvjqlb3fcx90xp7n9kr2z0byzyzg"))))
+ (build-system python-build-system)
+ (arguments
+ ;; TODO: (Sharlatan-20210207T165820+0000): Tests depend on astropy, astropy
+ ;; depends on asdf. Disable circular dependence.
+ `(#:tests? #f))
+ (native-inputs
+ `(("packaging" ,python-packaging)
+ ("semantic-version" ,python-semantic-version)
+ ("setuptools-scm" ,python-setuptools-scm)))
+ (inputs
+ `(("importlib-resources" ,python-importlib-resources)
+ ("jsonschema" ,python-jsonschema)
+ ("numpy" ,python-numpy)
+ ("pyyaml" ,python-pyyaml)))
+ (home-page "https://github.com/asdf-format/asdf")
+ (synopsis "Python tools to handle ASDF files")
+ (description
+ "The Advanced Scientific Data Format (ASDF) is a next-generation
+interchange format for scientific data. This package contains the Python
+implementation of the ASDF Standard.")
+ (license license:bsd-3)))
+
+(define-public python-astroalign
+ (package
+ (name "python-astroalign")
+ (version "2.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "astroalign" version))
+ (sha256
+ (base32 "19qzv3552lgrd9qmj0rxs51wmx485hw04cbf76ds5pin85kfaiy1"))))
+ (build-system python-build-system)
+ (arguments
+ ;; TODO: (Sharlatan-20210213T162940+0000): I could not make tests run
+ `(#:tests? #f))
+ (inputs
+ `(("numpy" ,python-numpy)
+ ("scikit-image" ,python-scikit-image)
+ ("scipy" ,python-scipy)
+ ("sep" ,python-sep)))
+ (home-page "https://astroalign.readthedocs.io/")
+ (synopsis "Astrometric Alignment of Images")
+ (description
+ "ASTROALIGN is a python module that will try to align two stellar
+astronomical images, especially when there is no WCS information available.")
+ (license license:expat)))
+
+(define-public python-skyfield
+ (package
+ (name "python-skyfield")
+ (version "1.36")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "skyfield" version))
+ (sha256
+ (base32 "1dm1327a4qv3klj9blrvddbhl72v1fqz52ym9km8qjj9vdkpywh6"))))
+ (build-system python-build-system)
+ (arguments
+ ;; NOTE: (Sharlatan-20210207T163305+0000): tests depend on custom test
+ ;; framework https://github.com/brandon-rhodes/assay
+ `(#:tests? #f))
+ (inputs
+ `(("certifi" ,python-certifi)
+ ("jplephem" ,python-jplephem)
+ ("numpy" ,python-numpy)
+ ("sgp4" ,python-sgp4)))
+ (home-page "https://rhodesmill.org/skyfield/")
+ (synopsis "Astronomy for Python")
+ (description
+ "Skyfield computes positions for the stars, planets, and satellites in
+orbit around the Earth.")
+ (license license:expat)))